Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While trying to install libmemcached via MacPorts, I hit the following issue:

     libmemcached @0.40 +universal
--->  Computing dependencies for libmemcached
--->  Dependencies to be installed: cyrus-sasl2 kerberos5
--->  Configuring kerberos5
Error: org.macports.configure for port kerberos5 returned: configure failure: command execution failed
Error: Failed to install kerberos5

It tells me to look in the log for details. Here's the last bit of the log file:

:info:configure checking for setupterm in -lcurses... no
:info:configure checking for setupterm in -lncurses... no
:info:configure checking for tgetent... no
:info:configure configure: error: Could not find tgetent; are you missing a curses/ncurses library?
:info:configure configure: error: /bin/sh './configure' failed for appl/telnet
:info:configure Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_kerberos5/kerberos5/work/krb5-1.7.2/src" && ./configure --prefix=/opt/local --disable-dependency-tracking --mandir=/opt/local/share/man
:info:configure Exit code: 1
:error:configure org.macports.configure for port kerberos5 returned: configure failure: command execution failed
:debug:configure Error code: NONE
:debug:configure Backtrace: configure failure: command execution failed
while executing
"$procedure $targetname"
:info:configure Warning: targets not executed for kerberos5: org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:error:configure Failed to install kerberos5
:debug:configure Registry error: kerberos5 not registered as installed & active.
invoked from within
"registry_active ${subport}"
invoked from within
"$workername eval registry_active \${subport}"
:notice:configure Please see the log file for port kerberos5 for details:
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_kerberos5/kerberos5/main.log

It seems to say it's missing ncurses. Looks like it's there though, since if I run port installed I see these:

ncurses @5.7_0
ncurses @5.9_1 (active)
ncursesw @5.7_0

Any ideas on how to get around this error?

share|improve this question

1 Answer 1

I got a similar error when installing subversion. Here's what worked for me:

sudo port install kerberos5

sudo port install subversion

... which for you would be libmemcached

So, what worked for me was to separately install kerberos5. Then, when subversion (libmemcached) is installed it finds it and the bug that causes it to fail when it doesn't find it doesn't happen.

share|improve this answer
    
This is what I get: sudo port install kerberos5 Error: Requested variants "" do not match original selection "+universal". Please use the same variants again, perform 'port clean kerberos5' or specify the force option (-f). –  ario Oct 16 '12 at 15:43
    
Then, sudo port install kerberos5 +universal ---> Computing dependencies for kerberos5 ---> Configuring kerberos5 Error: org.macports.configure for port kerberos5 returned: configure failure: command execution failed Please see the log file for port kerberos5 for details: (and the same error) –  ario Oct 16 '12 at 15:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.