Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a FAT32 external hard drive where I keep backups downloaded from webserver. I have a directory with 30 subdirectories. One of the subdirectories contains 21381 files and when I try to copy more files into this directory I get 0x80070052 error. However,it's possible to copy one more file in this directory (only one) if I make it's name shorter (8 characters instead of 22 as it's original name).

How do I solve this problem? Now I can not synchronize external hard disk files with server files which is very important for me.

share|improve this question
You may have a corrupt drive. Is reformatting it a possibility? – martineau Jul 7 '12 at 21:07
up vote 1 down vote accepted

I don't think FAT32 has a file limit that's specific to one folder, but the total number of files on a FAT32 volume is limited to 268,173,300 with 32kb clusters. This number decreases the smaller your clusters are, because the filesystem can only address so many clusters. So eventually if you use really small clusters, you will run out of clusters.

However, a quick google for your specific error message yields this page; which says that the problem was having too many files in the root directory of the volume (i.e. not in any subfolder). So you might want to try removing some files or folders from the root folder if possible. I'm not sure if this will help you.

Of course, the other option would be to not use FAT32. exfat and NTFS are both suitable.

share|improve this answer
There are only 10 directories in the root directory on no files at all. – tfs Jul 7 '12 at 14:50
I tried in safe mode. The same problem :( – tfs Jul 7 '12 at 15:05

I had the same problem (FAT32 external HDD, backups not being written etc.). Having read the above answer (thanks allquixotic!) (and others elsewhere, only some of which said more or less the same thing) I moved half the 514 files in the root directory into a subdirectory - and my problem was solved. (But I'm left wondering why it didn't return when I put those files back. Odd, that.)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .