Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed Crashplan on my MBP running OS X Lion. Crashplan is extremely slow in uploading all my files. Sitting overnight, it only has backed up about 4GB out of 450GB. Crashplan itself shows that it is uploading at about 750Kbps to 800Kbps. However, running a speed test (while Crashplan is uploading, I might add) reveals that I have upload speeds upwards of 3Mbps. I've followed Crashplan's instructions on how to speed up the backup, but it really didn't help. What can I do to fix this issue? I don't want to wait 50 days until all my data is backed up!

share|improve this question
    
This sounds typical. It took about three months for my 1.2 TB to be backed up. –  KronoS Jul 7 '12 at 17:59
    
How long is "overnight"? 4 GB in 5 hours is about what you'd expect from a line with a 2Mbps speed. –  David Schwartz Jul 7 '12 at 19:34
    
Overnight is about 9-12 hours. I wasn't really paying attention, but it should have done more than that. The main thing that bugs me is the fact that my Internet is 3mbps up and Crashplan is only using 800kbps of that; less than half of the available bandwidth. –  daviesgeek Jul 8 '12 at 3:33
    
Crashplan is also doing de-duplication/compression on your data, so you might not max out your outgoing bandwidth. But still, I am experiencing the same slowness-- on similiar backup loads (jpgs, ~75 gigs), my Windows Crashplan backed up much faster (pretty much overnight) while OSX Crashplan says it'll take a week. –  Nicholas Mar 13 at 15:09

1 Answer 1

up vote 5 down vote accepted

Sounds like the problem is at their end. Or your data is not going to a server that is closest to you.

you might want to try this to change your server, but be warned that you will have to restart the backup all over and loose your current settings: Changing your CrashPlan Central server for better backup speeds

...How do I switch servers?

Well, turns out you can assign your box a new machine GUID (a random identifier) and it’ll get assigned to a new home server randomly.

In order to do this you double click the CrashPlan logo (a green house) twice on the main screen and type in the command “guid new”. This will reset your local CrashPlan instance requiring you to set it up as a new computer, losing all your configurations, even local backups. Not only that, you will have to start back over with your initial backup. You have been warned! You’ll want to delete the old instance for your computer on the Destinations tab after you have made a successful backup, too.

You should find what server it is using right now, and where it is... and if you try resetting using the above information, you should check again and see where it will be going and see if it is closer and not the same server again or even farther.

share|improve this answer
    
The only problem with this is that it's another randomly generated server being selected. That's not exactly going to pic he closer one. –  KronoS Jul 7 '12 at 18:00
    
Thanks! I will try that. –  daviesgeek Jul 7 '12 at 18:02
    
Seems like this worked for me. Crashplan is now using 2-4 Mbps and says I only have 12-16 days. Thanks so much!!!! –  daviesgeek Jul 16 '12 at 22:35
    
Very good advice. I have a gigabit server both up and down. I Was connected to one server that gave me 500Mbps burst then slowly dropped to ~2Mbps. Great for small changes, but bad for the initial backup, for sure. Connected to another server and now I have sustained 30-40Mbps upload. Thanks. –  NickWoodhams Dec 23 '12 at 11:00
1  
Quick update, I started getting throttled once I uploaded a couple gigs. Sustained 8mbps, so about 1MB/s... at that rate I will never have the server backed up. Back to the drawing board... –  NickWoodhams Dec 29 '12 at 9:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.