Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a problem with a VIA C3 (1GHz)-system: the system freezes immediately when the CPU frequency goes under 731MHz because of an incompatibility with the (not completely implemented) i686 commands and a powersave feature of the kernel.

There is a workaround: deactivate the "longhaul" kernelmodule via alias longhaul off in /etc/modprobe.d/aliases.

But the system freezes before I can install any Linux distribution - even Clonezilla freezes.

Is there a possibility to deactivate the module with a GRUB boot parameter before the kernel is loaded?

share|improve this question
    
Add longhaul.enable=0 as a boot option. Based on some reading, I think @lornix might have gotten in backwards because some other folks gave the advice. See, for example, Longhaul problems - how to deactivate? – jww Feb 2 at 5:05

From what I can find, it looks like adding this to your grub boot line will disable the longhaul cpufreq module.

longhaul.disable=1

Once you're booted, of course, add that to your grub configuration so it sticks around without your intervention. You might add an additional boot entry in your grub menu WITHOUT this parameter so you can 'test-boot' to see if a later kernel has resolved the issues you're experiencing.

share|improve this answer
    
For the 4.2.0 kernel, longhaul.disable=1 results in dmesg "longhaul: unknown parameter 'disable' ignored". It looks like longhaul.enable=0 is the magic, but its noisy too: "longhaul: Option "enable" not set. Aborting." – jww Feb 12 at 22:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .