Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to use Sigil, which isn't in the official repositories. First I added a repository called home_xwaver and installed it from there, but it started throwing errors, unable to save a book. I found a blog post telling me to change some libraries, but I couldn't find the installation location of sigil. The executable was in /usr/share/bin, but I found no folder containing libraries, it wasn't in the default location of /opt/sigil.

As a second try, I deinstalled the package and tried to download it from its homepage. I downloaded the source and tried to compile it. It turned out to require QT 4.7.0, and the one I have installed is 4.8.2, so it wouldn't compile. I don't know where I can change the required version, and if it will work at all if I compile it with the new QT.

Edit some details: Sigil has no configure file. The docu says to run

cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release /path/to/extracted/folder
make
sudo make install

But the cmake line already fails for me. The error is

CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:97 (MESSAGE):
  Could NOT find Qt4 (missing: QT_QTWEBKIT_INCLUDE_DIR) (found suitable
  version "4.8.2", required is "4.7.0")
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:288 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake/Modules/FindQt4.cmake:1172 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  src/Sigil/CMakeLists.txt:37 (find_package)

The third thing I tried was a compiled file from the home page. I didn't have high hopes, because it is deprecated. (Currently, there is no non-deprecated Linux installation file on the home page, only Windows and Mac files). It started a graphical installer which hung itself in the middle of installation.

Is it possible to install Sigil on the current Fedora, and how can I do it?

share|improve this question

3 Answers 3

You need to install the qtwebkit-devel package:

yum install qtwebkit-devel

You may need other -devel packages, but that won't be obvious unless cmake crashes again complaining of something missing.

share|improve this answer

Installing from source isn't best way on GNU/Linux. If available use always binary or source packages. I hope Sigil will hit official repositories as soon as possible. For now following may help:

share|improve this answer

The following works for me on Fedora 17 64-bit:

yum install qtwebkit-devel boost-devel
cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release
make
make install
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.