Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just added a new ubuntu9.04 desktop machine to my network. Using rsnapshot (scriptontop of rsync) to backup all the machines.
But I'm getting denied error on the new machine.

The system works perfectly with the other Ubuntu and windows machines.
I can list the shares on the new machine so rsyncd and the network is ok.
I have the same rsycnd.conf and rsyncd.secrets files and they have the same permissions.
The log on the client just says "rsync denied"
Rsnapshot is using a dummy user that doesn't exist on any of the client machines

Obviously I have done something on the existing Ubuntu machines to make them work - but I have no idea what!

eg.

rsync rsync://backup@192.168.0.100:/home --password-file=secrets

Works for the old machine, gives permission denied on ".101"

share|improve this question
    
Are you sure rsync can access the local data? –  user7963 Sep 21 '09 at 19:54
add comment

2 Answers 2

up vote 1 down vote accepted

I copied the rsyncd.conf from the working system to the none-working one and it worked.

Probably rsync is fussy about tabs vs spaces or trailing spaces in config files?

share|improve this answer
    
why don't you just run diff on the two config files? –  Kim Sep 22 '09 at 9:35
    
They were on different machines and it didn't occur to me that this was the problem - I thought there was some security setting somewhere that I had set on the old machine and forgotten about. –  Martin Beckett Sep 22 '09 at 18:04
add comment

As far as I know Ubuntu 9.04 has AppArmor. This simply means that there are more security restrictions in place. Perhaps this is what you are running into?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.