Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to forward my public ip address with port 80 to a xampp webserver.

I have an ADSL modem and a wireless media router.

I have done the following:

  1. Reserved a DHCP address inside the wireless router (using the mac address hosting the webserver) so that my ip address never changed when I connect to the wireless router.

  2. Setup a Virtual Server port forwarding to TCP/UDP port 80 inside the wireless router so that it forwards to my http server.

Whats happening:

When I type my public ip address into my web browser it goes to my ADSL modem and not my webserver or my wireless router. Unfortunately the modem is not wireless so we got a wireless router installed. In the DHCP server settings of the modem, it has DHCP activated with a range from to I do not know what those addresses are. I did try to put in my own actual Internal IP Address but I wasn't allowed as ip address wasn't in the range of to

So internet still works, my router address works.

  • Wireless Router: DIR-855
  • ADSL Modem: DSL-502T

Anyone knows what I should do?

share|improve this question
Are you inside your network and trying to access your webserver using the public address? This is called hairpinning and is unlikely to work with a domestic router. Have you tried from outside the network? – Paul Jul 9 '12 at 6:43
yes, I am trying to access the webserver in a webbrowser from one of my lan reserved ip addresses by typing in the public ip address. No I haven't tried to access it from outside the network as yet. – Ben Jul 9 '12 at 6:48

I realised that I am supposed to have the modem bridged to the wireless router. I selected bridged for the modem and then PPOE for the router, then entered in the PPoE details from the modem into the wireless router and it worked fine.

Now when I type in the public IP address into the router from my PC, it launches my website.

Solved that problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.