Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I'm trying to search for a Java class with Ctrl-shift-T (Open Type popup), Eclipse freezes when I'm typing 1 character. It usually takes about 8 seconds to 'unfreeze', but sometimes it won't come back at all.. When it freezes, I see that the eclipse process takes about 1Gig of mem and the CPU is about 100%!

I've tried creating a new workspace, adjusting the eclipse.ini (perm size, different memory values), starting with -clean and at last reinstall the whole IDE. Nothing helps..

My eclipse.ini:


I'm using the following plugins: JRebel and m2e. I'm desperate for a solution because this problems causes me a great deal of time loss.

System: Ubuntu 12.04 LTS 64 bit, 4GB mem, Intel core i7 860 @ 2.8 Ghz.

Hope somebody knows a solution. Thank you for your time.

share|improve this question
up vote 6 down vote accepted

I had the same issue... i think. It's related to this:

It's an issue with GTK. try to remove libgail18. The issue is resolved, So I think it will be in the next maintenance version.

share|improve this answer
Thanks so much, this works for me! – NickGreen Sep 24 '12 at 7:25

I did not want to remove libgail18 package entirely, because there are too many things that depend on it, so I simply renamed /usr/lib/x86_64-linux-gnu/ to

This makes Eclipse fast again and gives me the option to re-enable the library if I need it for something else.

share|improve this answer

[Not an answer, but I'm not able to comment on your question]

I suffer from the same problem where Open Type hangs Eclipse for prolonged periods, typically around 2 minutes making Eclipse unusable. This only happened about 2 months after using this machine daily as a development machine.

Unfortunately I haven't managed to get to the bottom of it either. Of note I'm also running an Ubuntu 12.04 LTS 64 bit machine (8GB memory, Intel® Xeon(R) CPU X3450 @ 2.67GHz × 4).

java version "1.6.0_24" OpenJDK Runtime Environment (IcedTea6 1.11.1) (6b24-1.11.1-4ubuntu3) OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

I've also tried the Oracle JDK, It didn't help.

I've tried installing many different versions of Eclipse:

  • 3.6
  • 3.7 (From & installed via apt)
  • 4.2
  • Spring Source All of which suffered from the same problem.

Trashing my .workspace & .eclipse directories and having no custom plugins didn't help.

What did help was creating a new user account on my box. Unfortunately this also only worked for about a month. This does give me hope that there is some cache or file in my home drive that I can could delete to work around the problem, but I haven't found it. I'm now faced with creating another user or getting to the root cause of the issue.

share|improve this answer
Hmm oke, so creating a new user helps, didn't know that.. Still hoping for a better, permanent solution though:)! So if you come accross some solution, please post it in this topic. – NickGreen Jul 17 '12 at 14:37

When faced with similar issue on Windows, adding clean option to 'startWCToolkit.bat' helped. I'm sure there should be similar script on Ubuntu too. An excerpt of file:

"rationalsdp.exe" –clean   -showlocation -debug 
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.