Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In the past when using Windows 7 I had no problem with using Flash on Firefox. Now I am having trouble using Firefox because it hangs when a page contain Flash. If I disable the plugin it works fine.

I have tried to reinstall plugin from adobe.com site and I still don't have this problem solved. It works fine in Chrome.

share|improve this question
    
Google Chrome uses its own version of Flash Player. Any issues you experience in either browser with Flash should be considered exclusive, for the most part. –  iglvzx Jul 9 '12 at 10:18

1 Answer 1

Adobe Flash 11.3 isn't all that stable... There's some workarounds listed on the linked Mozilla Support page.

Personally, I would make sure Flash is up to date first, and possibly uninstall it (through Windows Programs and Features) and reinstall it (http://get.adobe.com/flashplayer/).

The next step is to try disabling hardware acceleration (right click on any Flash applet and click settings).

Finally, the workarounds on that page:

  • If it's crashing, install 10.3 or 11.2 (http://mzl.la/LdjZH6)

  • If Flash based videos and games are not loading correctly (but not actually crashing), first try turning off the web download feature of RealPlayer. Then try removing the RealPlayer Firefox extension. Finally, try uninstalling Realplayer. If none of that works or you do not have RealPlayer installed, try downgrading Flash (see above) (http://mzl.la/LA0mpi)


It seems to be a new "protected mode" feature: http://kb.mozillazine.org/Macromedia_flash#Flash_Player_11.3_Protected_Mode_-_Windows

Disabling Protected Mode in Flash 11.3

You can disable Protected Mode in Flash 11.3 by adding the line ProtectedMode=0 to the Flash mms.cfg file located in:

(Windows 32bit) C:\Windows\System32\Macromed\Flash 
(Windows 64bit) C:\Windows\SysWOW64\Macromed\Flash 

For example, on a Windows 7 64-bit system, open the C:\Windows\SysWOW64\Macromed\Flash folder, copy the file mms.cfg to the desktop, open it in Notepad, add a new line ProtectedMode=0 and then close Notepad, saving your changes. Next, go back to the C:\Windows\SysWOW64\Macromed\Flash folder, rename the original file to mms.cfgBAK (to save it as a backup) and then drag and drop in the modified mms.cfg file from the desktop. You can later re-enable protected mode by either restoring the backup or by editing the mms.cfg file to remove the ProtectedMode=0 line you added.


Full links (in case the above ones break)

http://support.mozilla.org/en-US/kb/adobe-flash-plugin-has-crashed#w_fixing-issues-with-flash-11-3

http://support.mozilla.org/en-US/kb/flash-113-crashes

http://support.mozilla.org/en-US/kb/flash-113-doesnt-load-video-firefox

share|improve this answer
    
Just a note, the links I'm using are not from some arbitrary link shortener, they are from Mozilla (You can use the link http://mzl.la/xxxxxx to easily share this article with others. It will display instructions automatically customized for their operating system and language.) –  Bob Jul 9 '12 at 10:45
    
When I uninstall it's removed from plugin list that's fine now when I install it it's show me two shockwave 11.3 or 10.xx I disable 11.3 of them and only 10.xx as enabled. now thing work fine but not sure why they listed two when I have one. Finally after a lot of days I got it worked on my server. thanks for it. –  Gupta Jul 9 '12 at 11:20
    
If you have two, first make sure you uninstalled all other ones through Programs and Features. Check for and remove any Flash plugins (NPSWF32.dll, flashplayer.xpt) from the Firefox installation directory plugins and components folders (inside Program Files). Same with C:\Windows\System32\Macromed\Flash (C:\Windows\SysWOW64\Macromed\Flash for 64-bit). Once you've cleaned all those directories, reinstall Flash. –  Bob Jul 9 '12 at 11:38
    
@user33631 I've also edited the answer to include a method of disabling a new feature in Flash 11.3 that's probably the cause of the issues. 11.3 and 10.3 have the same security fixes (that 11.2 lack), but 11 also has more features some applets may need so it is preferable to use 11.3. –  Bob Jul 9 '12 at 11:39
    
I can't try these thing on server now.it's work fine already. not want to be in trouble once again. –  Gupta Jul 9 '12 at 11:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.