Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am building a Custom Ubuntu ISO. Everything is ready in custom-iso folder. Therefore I apply this script to build my ISO.

#!/bin/bash
isoname=$(date +"custom-ubuntu-%y-%m-%d-%H:%M.iso")
mkisofs -J -l -b isolinux/isolinux.bin -no-emul-boot -boot-load-size 4 -boot-info-table -z -iso-level 4 -c isolinux/isolinux.cat -o ./$isoname custom-iso/

However, in this method I am losing long file names and this causes installation to fail. For example:

What installer looks: fs-secondary-modules-3.2.0-23-generic-pae-di_3.2.0-23.36_i386.udeb
What it finds: fs-secondary-modules-3.2.0-23-generic-pae-di_3.2.0-23.36_i386.ud 

How can I allow the mkisofs to have longer filenames?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

By -J you acttivate the short Joliet format (max 64 characters). An alternative is the long version: -joliet-long

Or you can try using the rock-ridge extension using the parameter -R or -rock.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.