Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am at a friend's house and cannot connect to his router. I have found a lot of suggestions on how to fix this but have been unsuccessful so far. I have tried manually assigning an IP to my computer ... the Airport now shows as connected but I cannot hit or anything on the internet from my computer.

When I try to connect to the accespoint normally, my Mac gets a self-assigned IP that appears to be totally random. Then I added a manually assigned IP of to my Mac, but it makes no difference. When I look at the router's admin area, all the connected devices have IPs in the range to

When I plug directly into the router, I get an IP of

Any ideas would be very much appreciated.

This problem has now happened on multiple networks and I have no answer. It is a real problem for me and appears to be a Mac issue, not a router issue.

I also discovered that while I cannot access the web, I can connect to Skype?

share|improve this question
More info would be helpful. What IP address does your computer have (192.x.x.x or 169.x.x.x)? What IP address does your friend's computer have? Can you connect wired for troubleshooting purposes? Can you paste the output when you type ifconfig in the – JoshP Jul 9 '12 at 15:52
Is it possible the router has an IP whitelist, and your machine isn't on it? – killermist Jul 10 '12 at 4:05
I will look into this but I have a PC, iPhone and iPad that were all able to connect without any problems. – Chris Jul 10 '12 at 15:22
up vote 0 down vote accepted

I also discovered that while I cannot access the web, I can connect to Skype???

Are you sure you're not having a DNS issue? Try manually setting your DNS in network settings, and are Google's.

The right answer here might be simply upgrading to Lion though, if possible.

share|improve this answer
That worked! Thank You. Also FYI - My Mac is "obsolete" and cannot run Lion. – Chris Jul 24 '12 at 16:16
Curious. Was there already some IP addresses there that you changed or was it empty? If there were some already there, it could have been a DNS changer virus! However, it's more likely that the DNS wasn't working properly on the router. Have your friend check the router settings if possible and see what the DNS settings are just in case something malicious was messing with them. A DNS changer virus will cause your machine to make calls to malicious servers even when you type a known to be safe URL. – ioSamurai Jul 24 '12 at 17:18
Yes there were already DNS entries in there. I will check the DNS settings on the router. – Chris Jul 24 '12 at 20:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .