Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm a Mac guy, and on a Mac, unless you have sticky keys turned on, all of the modifier keys at the bottom left of the keyboard work exactly the same way: you can press them all you want, and they will do absolutely nothing unless another key is pressed with them.

On windows, the behavior is quite a bit different. The Windows key, obviously, opens the Start menu, and the alt key, if struck once on its own, will prep for a menu keyboard shortcut.

This drives me nuts since I use alt-tab quite a lot, but occasionally will mistakenly hit alt on its own, requiring me to strike it again to toggle back to regular keyboard input instead of menu shortcuts. As far as I'm concerned this is really unintuitive, since alt is used all over the place as a modifier key, but ALSO has a function if you just strike it on its own.

How can I disable that sticky key function entirely?

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

I doubt there is any built-in way to do it (e.g., with a registry entry), but it is simple enough to accomplish with an AutoHotKey script (you can also compile the script and auto-run the resulting file in the background).


The following script allows Alt+whatever to work as normal, but Alt by itself does nothing*.

~RAlt & * ::
 RAlt     ::
~LAlt & * ::
 LAlt     ::

*Holding Alt down does do something: it displays the accelerator key underline if the Don’t-Show-Accelerators-While-Typing option has been set. Of course in this case, it actually is a feature as opposed to a bug.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.