Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had a certain block of data in a spreadsheet I was trying to create a graph (chart) from. I spent over an hour trying to figure out what was going wrong with my chart settings. I tried cutting and pasting the data to new cells... no luck. Eventually out of frustration I manually re-typed the data into new cells. It charts fine! You can even re-type it in the CURRENT cells and it charts fine! Incredibly frustrating. I have gone over cell properties with a fine toothed comb, etc... can find no differences. Please see linked file and see if you can figure this mystery out. It will be obvious once you open the file, I have two tiny test tables which appear identical, but one will plot a chart, and one will not.

test.xlsx

How frustrating. I spent hours today troubleshooting IE7's JavaScript quirks, and now this. Gotta love MS!

share|improve this question
    
Link seems to be dead. –  pnuts Apr 11 '13 at 21:05

2 Answers 2

up vote 4 down vote accepted

The issue is very simple. In the "won't graph" table, the numbers are stored as text. To fix this, just retype the numbers, click on the green prompt to the side of the box, or paste it to and from another application (excel should autodetect it as a number).

Some other methods

share|improve this answer
    
adding some of the information in the link will make this a even better answer for future readers –  datatoo Jul 10 '12 at 13:46
    
Thanks, of course you are correct. The most frustrating part is that "Technique 3" from the link you posted did not work in this case. In fact I had been trying that method several times before making this post. "Formatting" the cells as numbers does not fix the issue. As far as the error checking boxes, I disabled that a long time ago as I got sick of seeing green triangles everywhere, which I realize makes me look stupid right about now. So in the future I know I can turn that on in a situation like this to enable the "convert" option since it seems not to be available anywhere else? –  The111 Jul 10 '12 at 16:44
    
@Johnson, what do you mean? You want the green triangles back? –  soandos Jul 10 '12 at 17:33
    
No, I know how to get them back (turn error checking on). What I mean is that simply changing the cell "format" to number does not fix the problem as "technique 3" seems to imply. The only real option is #1, which requires the "convert" button, which only seems available through the error checking menu (which I previously had disabled). Which seems kind of lame. The worst part is if you change format to number, you can do math on those cells, so obviously excel is aware of their numerical values. Yet STILL refuses to plot them (actually, you can do math even with "general" format!). –  The111 Jul 10 '12 at 18:08
    
@Johnson. For Excel 2007 you can still (understandably!) avoid the green triangles by typing "1" somewhere and copying that cell, then select the values formatted as text. Paste, Paste Special, All and Multiply should convert to a number format. –  pnuts Jul 18 '12 at 16:48

The easiest way to do this is to type the number 1 in another cell, copy it and then "paste special" it by multiplying. All the cells will turn to numbers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.