Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just changed over my modem to bridged mode, and changed my wireless router to PPPoE. My PC IP address is reserved and forwards port 80 to my computer's IP address based on my MAC address.

I have a problem, however. I cannot access my local webserver by public IP address or my router 192.168.0.1 wirelessly from any other computer or iPad. I can, however, connect by this PC which is connected to the wireless router via ethernet. Via wireless, it says it cannot connect, however DNS addresses work (e.g. google.com, etc.)

Any ideas?

share|improve this question
    
In your router configuration is the option of separating local ethernet and wireless networks turned on? If it is, it may be the culprit. Try to turn on as much logging in your router as possible and check the logs for errors. Pasting those here would make it easier to give a reasonable answer. –  jpe Jul 10 '12 at 7:44
    
Can you connect to public sites by IP address? For example, here's an IP address-based URL for one of the addresses that "google.com" resolves to. Does this link work form your network?: 74.125.224.132 –  Spiff Jul 10 '12 at 8:08
    
Hi there Spiff, I can connect to 74.125.224.132 from the ipad and it works fine. I tried connecting to 74.125.224.132 from the laptop and eventually it loaded. I can also connect to 74.125.224.132 from my pc. –  Ben Jul 10 '12 at 8:26

1 Answer 1

If you can't connect to your local webserver by connecting to the public IP address of your NAT gateway, it means your NAT gateway doesn't do "NAT hairpinning", which is sometimes also called "NAT reflection". Make sure you have the latest firmware on your gateway, and look to see if there's a similarly-named setting you need to enable. If not, look at installing aftermarket firmware like DD-WRT onto your gateway, or look at getting a better gateway.

I don't know why you can't connect to your router's on web-based configuration page at 192.168.0.1, unless the presence of the port mapping for port 80 is somehow stealing port 80 on the WLAN side as well. You could temporarily try deleting that port mapping and see if you can connect again at 192.168.0.1. By the way, are you sure that's your gateway's WLAN-side IP address?

share|improve this answer
    
By WLAN-side ip address, i think your referring to the public ip address provided by the ISP. Yes I got the right one. Yes the router address is 192.168.0.1. It's a dlink. –  Ben Jul 10 '12 at 8:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.