Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

OSX 10.7, Adobe Illustrator CS 5.1

When you save a PDF in AI, it automatically opens in Apple Preview (or whatever PDF application you have set as default). So, if you're editing several PDFs, and you like to save often (which is wise), your work is continually interrupted by application focus shifting to Preview. Aggravating to no end.

I've searched high and low for an answer to this seemingly trivial issue; it's not in Preferences, and I can't find anything on help sites or the broader Web.

I'm trying to keep Illustrator from opening a PDF at all when it saves, not just trying to change the default PDF application for my machine.

share|improve this question
@Luke 's answer may still work though. If the pdf is presumably still open in AI (you're still editing it), any default action to open the pdf with AI (you just changed the default pdf app to AI) would likely just focus on the pdf (which you're still editing)... no? – JoshP Jul 11 '12 at 16:19
I suppose it's an effective workaround, although I like having Preview as my default PDF reader. I use it all the time for lightweight PDF use, reading tech books, etc. Suppose I could write a script to toggle back and forth... seems inelegant, though. Why does AI open the files in the first place? – niteshade Jul 12 '12 at 3:07
I understand the sentiment. I am also a fan of the lightweight Preview – JoshP Jul 12 '12 at 14:16
up vote 0 down vote accepted

Assuming you want to open ALL PDFs in Illustrator...

  1. Find an Illustrator-created PDF file
  2. Right click it and click Get Info
  3. Expand the section of what application to open it with.
  4. Choose Adobe Illustrator from the list, and tick the box to always use this application
  5. Close the window, and open the file

This should make all PDFs open in Illustrator. As for only CERTAIN PDF files opening in Illustrator, I don't know if that is possible, other then manually choosing Illustrator from the Right-click->Open With menu

share|improve this answer
hmmm... maybe still not being clear. The problem is that the PDF opens automatically, while using Illustrator. So I have example.pdf open in Illustrator, I make a change and save it; Preview opens with my latest save, stealing focus. Windows XP-style distracting behavior. The problem is not deciding with which program to open the file, but keeping it from opening at all. – niteshade Jul 12 '12 at 17:41
To keep Illustrator from openning the file, or Preview? – Canadian Luke Jul 12 '12 at 17:42
The file is already open in Illustrator. Every time I make a change, it opens it again in Preview. So it gets opened twice. It's a bug. – niteshade Jul 12 '12 at 17:43
Ahhh... My only suggestion is to remove then, but I highly doubt that's what you're after. Sorry – Canadian Luke Jul 12 '12 at 17:46
Turns out, I was being dense. This does indeed fix the problem, just not in the way I'd intended; it's a workaround, but it works fine. Option-Command-I will allow this to apply to an arbitrary group of images, without changing defaults. +1 – niteshade Jul 13 '12 at 19:07

Open the offending file and "save as", keep same file name and allow it to replace, when the Illustrator PDF save window opens uncheck "view PDF after saving".

share|improve this answer

With your PDF open in Illustrator:

  1. File > Save As...
  2. Uncheck View PDF After Saving
  3. Select Save PDF
share|improve this answer

You must log in to answer this question.

protected by slhck Oct 24 '14 at 12:31

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .