Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently compiled gVim 7.3.592 using gcc 4.7.1 from the MinGW distro available through nuwen.net. It was built with Python 2/3 and Ruby language interfaces (or more specifically, I had set the PYTHON, PYTHON3, and RUBY definitions in the makefile for MinGW).

Here's my gvimrc. I have a vimrc file that looks exactly similar.

For some reason, though, it looks like this:

enter image description here

How do I bring back the toolbar that was present in previous versions?

UPDATE: The issue occurs when I move the generated gvim.exe file out of the src directory into any other one. Bringing it back restores the toolbar icons and the menu.

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

If you type :e $MYVIMRC and then add the following and restart GVim, you should get things back to normal.

set guioptions+=m "adds menu bar

set guioptions+=T "adds toolbar

set guioptions+=r "always present scrollbar

You can also refer to the manual for a big list of options.


I decided I would try and go further and actually compile this myself. Downloaded the aforementioned Ming clone, and then cloned the vim repository. I compiled it with no plugins initially, and then compiled it with all combinations of plugins (Ruby, LUA, Python, and Perl thrown in for good measure).

I haven't gotten the glitch you've gotten so far, and through the chat you've told me that your compilation on another machine works as well. From that, it's definitely something quirky in your build environment.

share|improve this answer
1  
I tried this, but it did not work. According to the manual, these options are already enabled by default. I don't understand why this would not work "out of the box," so to speak - I've compiled gVim the same way before, and everything worked fine. –  Isxek Jul 11 '12 at 0:26
    
Can you provide a link to where you got your vim version from? I want to give a shot at compilation but I can't seem to find it via vim/devel –  qweet Jul 11 '12 at 0:46
    
Thanks for looking into this. I got the source from code.google.com/p/vim (just cloned the repo). –  Isxek Jul 11 '12 at 0:47
    
I just compiled 592 without perl, ruby, python (I'm going to recompile with each of these options in a sec). It displays the correct things for me. Did you try compiling multiple times, or was this the first runthrough? –  qweet Jul 11 '12 at 2:00
    
Trying it now... –  Isxek Jul 11 '12 at 2:15
show 2 more comments

Inside the location where gvim.exe was moved into, create a new directory named vim73. At minimum, the following files and folders should be inside vim73:

  • menu.vim
  • the autoload directory
  • the colors directory

I did not check further which particular files within either the autoload and the colors directories were actually needed, but fulfilling this requirement solved the issue for me.

share|improve this answer
add comment

:h guioptions for more information. Vim has a great documentation :)

If you want a quick answer:

if has("gui_running")
  set guioptions-=m     "remove menu bar
  set guioptions-=T     "remove tool bar
  set guioptions-=r     "remove left scroll
  set guioptions-=l     "remove right scroll
endif
share|improve this answer
    
This is more of an rtfm comment than an answer. While it is OK to suggest that the OP read the documentation, if you are going to answer, please provide an answer. –  MaQleod Jul 13 '12 at 18:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.