Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For those that are unaware, KSOD means blacK Screen of Death. Essentially, when windows starts my computer shows only the cursor and a black screen. It seems like any and all shell elements are disabled (or perhaps not started). I have seen a number of these questions asked, none of which have matched my situation.

  1. CTRL + ALT + ... does not respond
  2. Restarting in safe mode, results in the same KSOD
  3. sfc /scannow seems to have no effect when typed at the command prompt that is accessed using the recovery tools via the install disk
  4. There are no restore points (System Restore is turned off)
  5. "Last Known Good configuration" was/is not available in the startup recovery list
  6. Left the computer on in KSOD state for approx 7 hours (went to sleep). Did not self-resolve.

Update to item 3:

sfc /scannow reports: There is a system repair pending which requires reboot to complete. Restart Windows and run sfc again.

However, Windows does not restart past KSOD.


Update to item 3 as per Soandos comment re: /offbootdir

sfc /scannow /offbotdir=e:\ /windir=e:\windows

"Windows resource protection found corrupt files but was unable to fix some of them. Details are included in the CBS.log..."

In reviewing the CBS.log, there's a) too much information and far too many "failures" that could be false positives as to the root of my problem.


Help and comments are most appreciated

share|improve this question
1  
How about sfc with the offbootdir and offwindir flags set? –  soandos Jul 11 '12 at 2:23
    
Just for completeness sake, what version of windows? Could you give any details on what you'd done previously? –  Journeyman Geek Jul 11 '12 at 2:26
    
Windows 7 64-bit pro. Soandos, I'll try that –  Brandon Bertelsen Jul 11 '12 at 2:29
    
Journeyman Geek, I havent tried anything save those options listed in 1,2,3 above. Well, other than performing Dell hardware tests as a JIC measure. –  Brandon Bertelsen Jul 11 '12 at 2:32
    
Have you tried any of the windows repair options? Disk scans, etc? –  techie007 Jul 11 '12 at 3:11
show 10 more comments

1 Answer

I have seen this/similar issue and in most cases, the system would return to normal after many minutes. How long have you waited? One case I had took over 45 minutes. You mentioned storage dvices specifically so here is what I discovered.

I found that a USB DVD-R that was connected caused this issue. Unplug and all was well. Same thing with a USB key on a different system.

Never discoverd the real "why" but the fix was to unplug a device. Once booted, all was well and the device could be reconnected.

BTW, have you tried Last Known Good?

share|improve this answer
    
Thanks David. I left it on for a few hours (approx 7) over night on the KSOD. I tried all possible permutations of connecting and disconnecting peripheral devices. Last Known Good was not available at the selection prompt. –  Brandon Bertelsen Jul 11 '12 at 23:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.