Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Bought a cable (sata to usb). took out the hard drive from laptop. connect the hd with the cable with my desktop pc (which has 2 high speed good hard drive. each 2 tb).

I ran a copy-item from powershell. but started to get "access denied" on m:\users directory.

What is the best way to recover users directory info from a hard-drive? I have tons of family pics and my kids school grade info.

share|improve this question

migrated from stackoverflow.com Jul 11 '12 at 3:56

This question came from our site for professional and enthusiast programmers.

3 Answers 3

The basic idea is that you don't normally have permission to view the user-specific home directory of other users, even if you mount the drive in another PC. You can override the filesystem permissions, but this involves granting permission to your user on the files/directories, and you probably have to take ownership of them as well, which will require a UAC check.

If you insist on doing it all from Powershell, you can: http://chrisfederico.wordpress.com/2008/02/01/setting-acl-on-a-file-or-directory-in-powershell/

If you want to do it with Windows Explorer, then you should just be able to ctrl+c and ctrl+v (copy and paste) from the source to the destination, and Windows Vista / 7 should prompt you for administrative privileges (a UAC check) to set the permissions so that you can read the files in the users directory of the other user.

If your user directories were encrypted on the laptop, you will not easily be able to recover the data unless you backed up the encryption key. See http://windows.microsoft.com/en-us/windows-vista/Back-up-Encrypting-File-System-EFS-certificate -- if you're not familiar with these steps and you know your data was encrypted, you probably lost it if you can't get your laptop working again.

There are many ways to set the permissions but the bottom line is you need to open up the permissions, and since you are an administrator on your desktop PC, you probably can do it (unless the original data is encrypted at the filesystem layer).

Oh, I forgot to mention: NTFS-3G on Linux ignores NTFS ACL permissions, making everything world readable/writable; so if you are REALLY stumped about the permissions despite all the help we provided so far, you can just boot up a Linux live CD and try to read the files from there. If that doesn't work, then I'd start thinking about disk corruption or whether the files might be encrypted.

share|improve this answer

I had this problem a while back when I was working in a computer repair store, the easiest solution is to add a simple set of keys to your registry that puts a "Take Ownership Of Folder" to the right click menu when you click on a hard drive or folder.

Here is a link that has a simple installer and un-installer for the script: http://www.howtogeek.com/?post_type=post&p=557

you may find it useful to just leave on your PC, never know when you may need to take ownership of a file.

share|improve this answer

You may need to adjust permissions on the drive contents. If you don't know how, try reviewing this MS kb article.

If you have full permissions on the drive and it was not encrypted on your laptop, you may be experiencing hard drive corruption or bad sectors. I would try using a data recovery tool like Testdisk to see what is readable/recoverable.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.