Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Alright, so I used this program (forget the name, but it's the first one on the software center under the search 'dock') to get a dock, and since I had the dock I didn't want the launcher. I tried a couple methods that apparently don't work on 12.04, then somehow I right clicked on this help widget that I on my desktop while trying to remove the icon from the dock and I saw 'Disable Unity' or something like that. Since I just got Ubuntu today I didn't know that it also meant that menu at the top. I tried restarting to fix it, but all it did was remove the dock, and now I can't open any programs except the system settings (from changing desktop BG) and the terminal.

Are there any commands I could use to try to fix this? Thanks, and sorry if I didn't explain this too well, but I really don't know what the hell happened.

share|improve this question

You could try to reset Unity to its default settings.

share|improve this answer

try unity --reset; unity --reset-icons in a terminal.

If you can't open the terminal, try Ctrl+Alt+F1, login, and run it in there.

share|improve this answer

You can select the type of session you want from the login screen prior to logging in (at the bottom edge of screen. AFAIK, this will be stored as your preference for subsequent logins.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .