Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Several applications cannot run in an Administrator account because they do not have permission to create files in the %APPDATA% folder.

Background:

  • Running 64-bit Windows 7 Home Premium Edition on a family computer.
  • We have one normal account, Family, which has been running as administrator and without a password.
  • I suffered a virus infection on the computer and made several changes, including a system restore, changing the account type of the normal family account to a standard user and assigning a password. The infection is solved, but I have been left in a state where several applications cannot run in the Family account because they do not have permission to create files in the %APPDATA% folder.

Symptoms include:

  • Some applications (Chrome, Office) work properly with no problems.
  • Some applications (eg Civilization III) give an Access is Denied error trying to create a file in c:\Users\Family\AppData\Local\Temp. the same applies even when I choose to Run as Administrator
  • Firefox gives a Firefox is already running error, which investigation suggests is really a permissions problem (Task Manager assures me it's definitely not already running).

Attempts to solve the problem:

  • Changed the Family privileges back to administrator and removed the password. No luck.
  • Ensured that the Family user has full control over the %APPDATA% folder.

Current state:

  • Stuck. Frustrated.
share|improve this question

1 Answer 1

up vote 0 down vote accepted

Have you tried creating a new account all together and trying that? If this works, I would recommend using this new account, and ROBOCOPYing your user files over.

As well, if you were deleting files, maybe some system files got removed. Try clicking Start, typing CMD and press Left Shift+Left Ctrl+Enter to launch as the Administrator. Type SFC /scannow and press Enter. This will have Windows scan for any system files that may have been affected. Pay attention to the output.

share|improve this answer
    
Thanks Luke. I tried the new account approach, although copying user files left me with some problems. In the end, I re-installed the major applications that were not functioning. The SFC command is not something I knew of before - thanks for that. I suspect that as a result of my previous attempts I was seeing two separate problems (at least). Thunderbird, for example, was failing to start for one reason (presence of a parent.lock file) while an old game (Civ III) was failing because it is not permissions-aware enough for Windows 7. Thanks for the response. –  Tom Slee Jul 12 '12 at 13:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.