Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two displays connected to a Ge-force 210 on my Dell running Ubuntu 12.04. One is using DVI the other VGA. The DVI display had a mode for its max resolution (1680x1050) which I selected. The VGA display did not for its highest res (1280x1024). I used gtf to make a mode line, created it, added it to VGA-1 and outputted it. The display flickered and auto adjusted leaving a correct width but a stretched height.

I kept trying the auto adjust on my display. As it runs through the process the display scrolls down the stretched desktop and back to the top. When I open the monitors on-screen display it says its receiving 1280x800!, while xrandr -q says it is outputting 1280x1024 at 60hz.

This problem is likely not an xrandr problem but the screen works perfectly on a windows machine at full resolution.

Any ideas?

share|improve this question
    
DVI sends the support resolutions. VGA does not. You need to select the correct resolution when using a VGA connection. This sounds like a ubuntu problem have you updated and install all required drivers? –  Ramhound Jul 11 '12 at 14:28

1 Answer 1

Are you using the nvidia binary drivers or Nouveau? If the latter, file a bug on freedesktop.org or try to get help on freenode IRC in #xorg channel.

BTW the askubuntu stack exchange site might be a better fit for this very Ubuntu-specific question.

share|improve this answer
    
I have other problems when using the nVidia drivers as well as this one. I am trying to sort out this resolution problem on the nVidia drivers now but I prefer using Nouveau because it gives native display support in system settings. I asked this same question in askUbuntu but didn't get an answer yet. –  roryhughes Jul 11 '12 at 18:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.