Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I run cmd.exe, its window doesn't show up.

Still, cmd.exe is listed in the processes list of the task manager.

And unfortunately, it doesn't figure in the taskbar.

Is the problem related to the file itself or the registry?

Repairing windows using the dvd did nothing

System: Windows 7 Ultimate 32-bits

share|improve this question

migrated from stackoverflow.com Jul 12 '12 at 5:27

This question came from our site for professional and enthusiast programmers.

    
Does it have a taskbar button? –  Synetech Jul 12 '12 at 5:46
    
Unfortunately, no –  久蔵 リファイ Jul 12 '12 at 6:58
    
Do I have to replace cmd.exe or edit the registry? –  久蔵 リファイ Jul 12 '12 at 10:34
    
What about superuser.com/questions/87441/… ? –  Shiki Jul 12 '12 at 11:11
    
@Shiki I tried PowerSell, Console and ColorConsole. All of them are alternatives but they don't solve completely the problem. –  久蔵 リファイ Jul 12 '12 at 12:59

3 Answers 3

up vote 2 down vote accepted

Try to delete key

[HKEY_CURRENT_USER\Console]

Save its contents in reg-file before deletion!

share|improve this answer
    
It works! Thanks –  久蔵 リファイ Jul 12 '12 at 13:34
    
That's strange; the console registry entry has no settings that should effect it having a taskbar button or not. o.O –  Synetech Jul 12 '12 at 20:17
    
Nothing strange. Just another bug from M$. I have already encountered this problem, while developing ConEmu. As far as I remember, the problem is in one incorrect value, not sure now what exactly. –  Maximus Jul 12 '12 at 20:31
    
"FullScreen"=dword:00000001 and oops. This "works" on 32-bit Win7. –  Maximus Jul 12 '12 at 20:47

The Window has been set to invalid screen coordinates, but it is easy to fix:

  1. Click the command-prompt button the taskbar
  2. Press the following keys:
    1. Alt+Space
    2. S
    3. Any of the arrow keys (e.g., )
  3. Move the mouse (the command-prompt window should now be on screen)
  4. Save the new position by pressing the following keys:
    1. Alt+Space
    2. P
    3. Enter or Return

Now close the command-prompt and open another one. The window should be on screen.

(Note, the method above for saving the position exploits a bug in Windows 7. You can select Defaults in the context-menu instead of Properties if Microsoft ever decides to fix the bug. Also, for Windows XP, you can do the same actions, but must select Modify shortcut that started this window after pressing Enter.)

share|improve this answer
    
This doesn't work, it doesn't have a taskbar button –  久蔵 リファイ Jul 12 '12 at 9:55
    
The window doesn't show up even for other .exe programs that uses the command prompt, like compiled c programs –  久蔵 リファイ Jul 12 '12 at 12:50

You can select your window on taskbar and press Winkey+arrow keys. This works with many displays as well (when you disconnect second display and program opens on it).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.