Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The flash drive is recognized as shown by /var/log/messages.log:

Jul 12 10:58:41 phelps kernel: [ 5865.612777] usb 2-1: new high-speed USB device number 2 using ehci_hcd

But I can't find its dev file in /dev or /dev/disk/by-id or /dev/disk/by-uuid. What could be the problem?

By the way, I am using the latest Archlinux. Thanks.

share|improve this question
add comment

2 Answers

It may be there as /dev/sdx, at least that's what it's like on my Ubuntu install.

share|improve this answer
    
There isn't any additional /dev/sd* besides my own hard drive. Interestingly, I can mount the usb drive in the Windows virtual machine inside my Archlinux box. –  RNA Jul 12 '12 at 15:54
    
@RNAer umm, is there any /dev/hd*? –  xiaomao Jul 12 '12 at 15:56
    
no /dev/hd* either –  RNA Jul 12 '12 at 15:56
    
try rmmod ehci_hcd and modprobe ehci_hcd as seen in bbs.archlinux.org/viewtopic.php?id=114077 –  xiaomao Jul 12 '12 at 16:04
    
rmmod ehci_hcd ran but modprobe ehci_hcd gave error with code 1. Still not mounted. –  RNA Jul 12 '12 at 18:54
show 1 more comment

If this is a phone (as it was in my case) change your settings from MTP mode to MSC mode. See: MTP or MSC

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.