Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am on a network that uses LDAP proxy for authentication based on a username and password.

Whenever I start Google Chrome, it pops up with a proxy authentication dialogue, but the dialogue disappears automatically after variable amount of time (sometimes it stays for 5 seconds some times less than 1 second). I have found the same issue with Chromium also.

Is there any configuration I can set to control this timeout, or say, auto-authenticate with my authentication details from the shell or DE (Gnome3 on Arch)?

share|improve this question
    
Which version are you using? I use chrome in Ubuntu and don't face any such problem –  Karthik Aug 16 '12 at 10:58
    
I am using chrome dev channel 22.0 on Arch –  Nihar Sarangi Aug 28 '12 at 12:26
    
Can you share a screen shot of dialog box and which Operating system you are using –  Ghost Answer Sep 24 '12 at 9:52
    
I am using arch linux. The authentication dialogue looks exactly same as the normal one, just that it auto goes off in a short time. –  Nihar Sarangi Oct 6 '12 at 20:39
1  
I'm getting the same thing. I would love if anyone knew of a resolution. Just started to today for some reason. I'm on Windows however. –  geoffrobinson Oct 9 '12 at 15:26
show 1 more comment

3 Answers

I've had a similar issue before which I resolved using by passing in the proxy parameters in the shortcut.

get the properties of the shortcut your using to start chrome and append this to the end

--proxy-server=SERVER:PORT 

Pays to use the IP rather than a hostname, seems to like it better.

If you're still getting the prompt then you might need to pass in your username and password, but that would be a last resort.

--proxy-user-and-password=USERNAME:PASSWORD

Hope that helps¬

share|improve this answer
add comment

[I cannot comment to your question, due to reputation although I think this should go into a comment as it is not my own answer]

From this previous SO question, the only workaround I found for this issue was the anwser given by Amos: auto-fill username/password from Chrome when the pop up arises, http://superuser.com/a/379382/54151.

I am also using Gnome (2 for what matters), and set automatic authentication with my credentials in the Proxy settings and it did not work. Although, it used to worked with no problem in my previous version of Google Chrome (current one is Version 23.0.1271.22 beta).

share|improve this answer
add comment

One of your Chrome extensions is causing this.

Go to chrome://extensions/ and disable each extension until the problem goes away.

For me, the cause was DataJog but it could be any of them for you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.