Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using my HTC Dream to control my home computer via SSH. But the interaction is very slow. I think this is because it uses the secure algorithm (aes256-ctr). If this is true, how do I make sshd use the simplest secure algorithm?

share|improve this question

migrated from serverfault.com Jul 12 '12 at 19:06

This question came from our site for professional system and network administrators.

    
SuperUser is a community on the StackExchange network, just like this one. It's just that your HTC Dream phone isn't really considered a server over here, though it clearly is running an SSH server daemon :) –  0xC0000022L Jul 12 '12 at 19:05
    
You need to define what "secure" means to you before anyone could tell you what algorithm is good enough for this scenario. –  Chris S Jul 12 '12 at 19:05
    
You may also be seeing tcp-over-tcp meltdown, depending on what you're doing: sites.inka.de/bigred/devel/tcp-tcp.html This sort of thing would more likely show up over somewhat lossy connections, such as a cell data network. –  cjc Jul 12 '12 at 19:23
add comment

3 Answers

You can change the ciphers used by modifying the config file at /etc/ssh/sshd_config.

Check out the man pages and you should be able to set the cipher to whichever you'd prefer. We've found blowfish to be the fastest.

http://man-wiki.net/index.php/5:sshd_config

You can also turn on compression if you'd like to try to speed up your connection.

share|improve this answer
add comment

While the HTC Dream is quite old it should easily suffice to encode/decode data with speeds of a simple SSH session. The slow interaction is rather caused by the higher latency in cellular networks. Any keypress will have to travel to the server and then get echoed back to the client.

Unless SSH is still slow when you connect through Wi-Fi, changing the cipher suite will not help.

share|improve this answer
add comment

Are you talking about initial connections? or while communicating with the unit AFTER connecting?

If you haven't either assigned a DNS name to that IP address, or at least giving a name to the IP addr in BOTH device's /etc/hosts file, then you'll experience a delay when connecting since the machines are looking up the addresses to get names.

Delays after connecting could be network load related, packet travel path related, device load related... pick one...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.