Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a very frustrating issue with a VPN connection initiated with Rasdial.

I have computers (Windows XP Professional SP2) which serve as an unmanned field measuring devices. They automatically initiate a VPN connection with a server over a UMTS connection through the use of a batch file that I call from an application.

For the connection to be initiated I use the following batch file:

rasdial vpnserver /disconnect

rasdial VPNserver stationname password

This works fine as long as the UMTS connection is up and healthy. However if the UMTS drops for whatever reason and then comes back again, I can't get the VPN connection up again. When I run the above batch file I get the error:

756 "connection is already being dialled"

I can't manage to get the connection "cleared" .The only way to connect again is through rebooting the whole computer, which is not acceptable.

I have tried to expand the batch file as follows;

rasdial vpnserver /disconnect

route -f

ipconfig /release

ipconfig /renew

arp -d *

nbtstat -R

nbtstat -RR

ipconfig /flushdns

ipconfig /registerdns

rasdial VPNserver stationname password

to try and reset anything which has something to do with networking. Sadly this doesn't have any effect, I still get the same error.

There must be something that gets reset by rebooting the machine, but I can't manage to find out what this is and how to do this from the command line.

How I can solve this issue without rebooting the whole machine?

share|improve this question
1  
From a quick look up this problem has been common with XP and Vista... could you use a different VPN client? OpenVPN as a different VPN technology so you're not relying on the MS API? –  Big Chris Jul 13 at 15:32
    
(1) Try to trace the problem as described here. (2) Disable all other network adapters. (3) Does the problem ever clear up after some time? –  harrymc Jul 14 at 5:45

1 Answer 1

rasdial /disconnect disconnects all connections, regardless of name

share|improve this answer
1  
Nope, not in this scenario, not when it "crashes". –  Lightness Races in Orbit Jul 17 at 15:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.