Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a webserver built at home, using Ubuntu Server, that is using Apache2 to host my website. At this moment, I am only interested in hosting the website on the inside of my network.

The server is called "flashnav-server". Using a PC, I am connecting to it by entering "http://flashnav-server" into the address bar. But entering the IP Address doesn't work.

The problem is that neither of these methods work from within a mobile device. You receive either an Apache error saying that I don't have permission to access / on this server. Or a 404 error.

I have changed permissions on all files required, to allow anyone full access and permissions. This has not sorted the problem. A laptop that also connects wirelessly, to the same access point as the mobiles, can still connect to the website; so I cant see it being a network issue. The "sites-enabled" and "sites-available" default settings pages have being edited to point to /var/www/ as well as all the folders inside the /www/ directory.

Any help that people can offer, will be greatly appreciated!

share|improve this question

migrated from stackoverflow.com Jul 13 '12 at 9:54

This question came from our site for professional and enthusiast programmers.

    
Do you have an index.php or index.html file in the root of /var/www/? –  travega Jan 18 '12 at 1:02
    
I originally had index.php but now I have put index.html in the /var/www/, no difference. –  roydunican Jan 18 '12 at 13:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.