Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have windows 7 and you know that little up arrow by the clock. There is a link when clicked and it is called about "customize" I click on it and nothing happens. It use to appear with a list of all my programs but now it does nothing.

I don't know why it does not work since no message comes up to tell me if something went wrong or something is actually doing something.

share|improve this question
    
If you right-click an empty space on the taskbar, select "Properties" and then on the "Taskbar" Panel select the "Customize..." button it will also not display anything? –  A Dwarf Sep 22 '09 at 0:19
    
Nope when do that nothing happens. –  chobo2 Sep 22 '09 at 0:55
    
Very well, writing a possible solution. –  A Dwarf Sep 22 '09 at 1:01
    
Are you using any custom UI addons or themes? –  John T Sep 22 '09 at 1:36
    
Nope no custom Ui or themes –  chobo2 Sep 22 '09 at 1:51

2 Answers 2

up vote 3 down vote accepted

We are going to restore your Notification Icons area functionality. Hopefully this fixes the problem, whatever it may be.


Because we are going to play with the registry, first thing to do is to make a backup copy of the registry you can later restore if anything goes wrong:

  1. Click the Start Button and type systempropertiesprotection. Press Enter.
  2. Answer to the UAC prompt(s) if they show up.
  3. On The System Properties dialog, you should be looking at the System Protection tab. Click the Create Button.
  4. Type a name for this restore point and then click Create. If System Restore is currently turned of, you will be asked about it and should answer accordingly so that System restore becomes active and this restore point assigned to your Windows partition.

If anything goes wrong with what we are going to do with the registry, here's how to restore your system:

  1. Click the Start Button and type systempropertiesprotection. Press Enter.
  2. Answer to the UAC prompt(s) if they show up.
  3. On The System Properties dialog, you should be looking at the System Protection tab. Click the System restore Button.
  4. Select the Choose a different restore point option and click Next.
  5. Select the restore Point you created previously and click Next.
  6. Click Finish and your system will be restored.


So, let's start by try and rebuild the information on the Icon Notifications area.

  1. Fire up regedit.
  2. Navigate to HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify
  3. Delete the IconStreams and PastIconsStream keys.

Now, the most important, albeit not very common process: This has to do with how Windows uses the Icons Notification area and how it creates and populates these keys.

  1. Open Task Manager
  2. Right-Click Explorer.exe and select End Process from the popup menu.
  3. Still on Task Manager, click on the File Menu and select New Task (Run...)
  4. Type explorer.exe and click Ok.

Why do this? Because forcing explorer to restart will ensure those two Keys we deleted are also removed from memory and not put back in place against our will when we do the next and final step. So, one last step:

  1. Logoff and log back on.


This will generate those two keys again and populate them only with applications currently on your tray icons area. Essentially it recreates the Icon Notifications list with a cleaned list. Your current problem is almost probably to do with corrupt data on one of these two keys, so this should fix it.

Let me know if it now works.

share|improve this answer
    
The sheer length of this answer must mean it's good! –  Breakthrough Sep 22 '09 at 1:30
    
Naw that did not work but I did find a system restore that I had and that fixed it. Thanks anyways. –  chobo2 Sep 22 '09 at 1:50

I just had this problem

I followed instructions to use gpedit to hide some icons in the Control Panel. After that the "customize" button of the System Tray stopped working exactly as described in this thread (No warnings, no errors, nothing).

This can be done in gpedit: navigate to User Configuration \ Administrative Templates \ Control Panel and in the right pane double-click on Hide specified Control Panel items. (this can also be done through regedit)

After disabling this directive everything worked fine again.

Hope this helps someone, at first I did not find any solution searching in Google and found this thread but it did not help. I had to restore a backup and later discovered that this was the problem.

(Windows 8 Pro 64, but I think it should be the same for some earlier versions of Windows)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.