Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm setting up Sublime to run with NodeJs on my Mac. I get the error below enter image description here

However, looking at my Path variable, /usr/bin/local is in the Path (I assume these are different?). Im interested to know why the Node plugin isnt pulling the same $PATH as I get in terminal.

enter image description here

share|improve this question
    
Duplicate: Setting environment variables Mac 10.6 — you need to set a different PATH for GUI. –  slhck Jul 13 '12 at 13:35
    
Above question helped me out - thanks. –  LiamB Jul 13 '12 at 13:48
add comment

2 Answers

Quick Workaround:

Just launch SublimeText2 via your Terminal by typing: subl Then the Plugin has the PATH that is otherwise not really initialized.

share|improve this answer
add comment

For GUI applications in Mountain Lion you need to set the PATH variable in /etc/launchd.conf. You cannot append to the existing PATH variable because this file doesn't have access to the environment variable. So you must overwrite the existing PATH variable. Also a restart is required every time you edit /etc/launchd.conf.

setenv PATH /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin

Source: Overwatering Blog - Setting the PATH on OS X Mountain Lion

share|improve this answer
    
I don't have this file. –  Nakilon Aug 18 '13 at 8:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.