Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 4-years old Biostar GF7050-M2 with one IDE port for two devices. WD400 and ASUS DVD-RW work great until one day I found that DVD recorder not available in My Computer. Bios shows wrong names for these devices.

Channel 0 Master [VDB VD400BB-45JK@01]

Channel 0 Slave [@STS DRV-0608PZR]

I tried new IDE cable, reset bios settings to default, remove bios battery.

share|improve this question
what have you done to determine that the issue is not the optical drive itself? Have you connected a different IDE device to the cable to see if it is detected? Have you connected the optical drive to another computer to see if it functions? Have you tried booting your computer to a LiveCD operating system (like Linux) to see if the problem is something within your current operating system? – Bon Gart Jul 13 '12 at 15:15
Yes, I have tried to boot working Live CD - it's not work. I can't test on other PC, but as you can see I have connected old HDD 40GB and it's shown with wrong label in Windows it was found also as some other HDD model and have wrong size 47Gb. – Eugene Jul 13 '12 at 15:18
Ok. Those are all details you need to include in the question, to keep people like me from asking if you did them. In general, it does sound like an issue specific to your motherboard... possibly your BIOS, or more specifically limited to just the IDE controller. Does the board work normally otherwise? Like... do you have a SATA drive to boot to, or a USB flash drive set up as a bootable device? – Bon Gart Jul 13 '12 at 15:21
Strange but all other functions (2 Sata drives, USB devices) work and system quite stable. – Eugene Jul 13 '12 at 15:28
and even as the optical drive isn't detected and the BIOS doesn't detect the names of the other IDE devices properly... can those other devices still be accessed normally on the IDE controller? Meaning, does the WD400 that is detected as a VD400BB still work normally once an OS is up and running? – Bon Gart Jul 13 '12 at 15:32

You must log in to answer this question.

Browse other questions tagged .