Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some reason, I am unable to run Warcraft 3 with the following specs

  • Model: satellite l655d
  • Processor: AMD turion dual-core processor 2.40 GHz installed
  • 4 GB RAM
  • 64 bit, Windows 7

Game was running fine prior to vacation and even during vacation. At first I thought maybe something messed up the graphics card during flight and it was overheating, but temperature shows normal 50-60c.

What can be wrong and how do I diagnosis? This game is very old and should have run fine.

The only thing that I can think of is something happened during the laptop restart. I used to have it hibernate/sleep instead of shut down and after the restart this begans to happen.

share|improve this question
    
Have you tried restarting normally and then running the game? And have you tried running it from a cold boot (shut down normally, leave it for ten to thirty minutes, then start up)? –  Blacklight Shining Jul 13 '12 at 16:22
    
yes, i have tried both, –  Frank Ly Jul 13 '12 at 16:50
    
You kind of forgot to describe the problem. You say just that you're "unable to run warcraft 3". Well, what happens when you try? –  David Schwartz Jul 13 '12 at 21:22
    
the game lags, and the frames per second are unusually low –  Frank Ly Jul 13 '12 at 21:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.