Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using a fresh install of Windows 7 64bit edition. I was previously using Vista 32 bit. Both times I was just using the default version of DirectX which came with Windows, which was version 10 for Vista and 11 for 7.

I am using the latest drivers for my video card, a radeon mobility 3650. On Vista 32bit, I installed IGI 2 and played it without a problem. I can not get it to run on Windows 7 at all. Whatever I try, compatability mode, different drivers, DirectX versions etc, I only get the error message "This application requires DirectX version 8.1 or higher".

Even searching for this error message returns only about 3 or 4 other, non-resolved similar problems. Does anyone have any suggestions?

share|improve this question

5 Answers 5

Most likely you are hit by a bug in the game, which checks for DirectX version in some bad way (like it looks for dll in some hardcoded directory, which is different for 32b and 64b OS). If you really need to solve this in a way other then dual booting your computer to 32b OS, I am afraid a lot of patient reverse engineering will be needed: you need to track the application to see which dlls it attempts to load, and once you know it, you could provide your own fake dll at that location (or perhaps copy default DirectX dlls there from system).

If you want to try this, I would recommend watching the application activity using SysInternals Process Monitor

share|improve this answer

In the past when I had problems like that, the program was trying to load a dll that for some unknown reason was missing from my DirectX installation, and I had to go out and find it on the web.
But I wouldn't know if this is what's happening to you.

share|improve this answer

I had a similar problem with Eve Online, and fixed it by installing DirectX 9.0c.

share|improve this answer
    
They are deprecated only in the sense new DX SDK no longer contain any tools to develop for them. The runtimes are still present, at least for 32b applications (some APIs, like DirectDraw older than 7, are not present for x64 apps). –  Suma Sep 30 '09 at 10:26
    
Thanks for the clarification, I've amended my answer. –  Hirvox Sep 30 '09 at 11:14

You Have to enable directPlay to run IGI 2, i myself running IGI 2 on windows 8.1 x64, without enabling directplay i get same error message.

Enable DirectPlay: go to controlpanel then Uninstall a program, then turn windows features on or off, when new window opened click and expand Legacy Components, tik DirectPlay and click ok. restart your System.

share|improve this answer

You may want to try running it in a virtual machine. Microsoft provides what they call Windows XP Mode through their Windows Virtual PC. Complete instructions can be found here: http://www.microsoft.com/windows/virtual-pc/download.aspx

share|improve this answer
1  
Games do not generally run well using virtual machine, as virtual machine support of 3D rendering is marginal (even GPU is emulated in SW, resulting in slow speed and only basic rendering capabilities). –  Suma Sep 30 '09 at 10:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.