Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an AMD Phenom II X4 955 that keeps going up and down between 800mhz and 3.2ghz. The multiplier also goes up and down between 4x and 16x. It does this several times a second regardless of load -- resulting in an incredibly frustrating hiccup.

I disabled Cool & Quiet in BIOS -- didn't change anything.

So I tried setting the CPU processor speed between 100% and 100% in Catalyst Control Center AMD VISION Engine Control Center -- still goes down below the minimum to 800mhz regardless. Of course, I made sure to set the power profile to High Performance.

So I tried disabling Cool & Quiet using an open-source tool called PhenomMsrTweaker -- still no difference.

Any idea what else could be causing this?

share|improve this question
    
You should work on fixing the hiccup rather than disabling features that are designed to help solve the very problem you're having. Start out by undoing all the changes you've made, then work on figuring out why it is hiccuping. Start by monitoring the CPU core temperature. –  David Schwartz Jul 14 '12 at 11:51
    
@DavidSchwartz How does Cool & Quiet help reduce hiccupping? It shouldn't hiccup if it stays at 3.2ghz. I'm pretty sure the problem is something to do with the clock multiplier up and down from 4x to 16x. –  Rei Miyasaka Jul 14 '12 at 12:00
    
Cool & Quiet reduces hiccuping by ensuring the CPU is cool enough to run at maximum speed without throttling when a burst of load hits. By forcing the CPU to try to run at high speed even when there is no need, you keep the CPU hotter and increase the chances that it will be unable to cope with load when that load appears. Return all settings to defaults and then troubleshoot the problem. –  David Schwartz Jul 14 '12 at 12:07
    
@DavidSchwartz Crazy, you were dead on -- I spent several days trying to nail down this problem, and guess what fixed it: a few bursts from an air can to the CPU cooler fixed it. Care to make a post so I can mark it as answer? –  Rei Miyasaka Jul 14 '12 at 12:21

2 Answers 2

up vote 1 down vote accepted

Your problem is most likely heat. Everything you are doing is just making the CPU hotter, making things even worse. Put the settings you messed up back to their defaults and then you can troubleshoot the real problem. (Which is most likely heat.)

share|improve this answer
1  
This is what happens when software people try to fix hardware problems... :P –  Rei Miyasaka Jul 14 '12 at 12:25
    
I was reminded of someone who was endlessly tuning a Solaris IP stack to try to get better ping times when his ping times were entirely due to the speed of light. I tried to explain to him, among other things, that if there was a magic "go faster" button, it would come in the on position. –  David Schwartz Jul 14 '12 at 12:26
    
Hah, it would come with a "reverse time" button too! Thanks by the way. –  Rei Miyasaka Jul 14 '12 at 21:11

To add to @David's answer, I also bought some thermal paste and re-gooed my CPU. That seems to have completely stopped the CPU speed from slowing down, even during the (summer) day.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.