Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have set up Microsoft SQL Server 2008 R2 (SP1) on a local machine specifically for a certain application to run.

The application itself is designed to use an IP address which is hard coded in to the application itself. Here locally, the application runs wonderfully.

The same application on a remote computer, with the IP address edited to my public IP, cannot connect to SQL Server.

  • Server Instance is running
  • Server Browser is running
  • TCP/IP is enabled
  • Remote connection is enabled
  • Firewall on server machine disabled (temporarily)
  • Ports open to server machine (even went as far as DMZ for testing purposes)
  • No ports are blocked by my ISP.
share|improve this question
    
what authentication method do you have set for the machine Windows or SQL Server and Windows(Mixed)? Do you get errors or nothing? Have you tried connecting with SQL Server Management Studio from outside? It may provide more of a clue whether it is the SQL configuration or your application. Event viewer on both machines may give some clues also whether you are reaching the machine at all, and it is then denying access or what –  datatoo Jul 14 '12 at 16:25
    
Have you consulted with the application vendor to find out if your setup is supported with a different IP address? What error message do you get? How long does it take for the error to appear? Can you connect remotely to the SQL instance using Management Studio (like @datatoo suggests)? Are you running a named instance, or is it the default instance? –  user3463 Jul 14 '12 at 19:37
    
I am using Mixed authentication. the application is a stand alone app and does not require SQL on the remote machine. The aplication can use any IP address the end use chooses to put in which i have put in the public IP of the server machine The server machine is using a named instance and is the only instance running. (new install of SQL) –  user145983 Jul 14 '12 at 21:21

1 Answer 1

A named instance might be the problem here, despite the fact that your firewall is wide open and you have SQL Server Browser running.

I would suggest setting a fixed port for the named instance, and creating an alias to that port in SQL Server Configuration Manager on the client (which means you'll need to install the SQL client tools).

You seem to know what you're doing, but if you need a walk-through, let me know and I'll flesh out my answer more.

share|improve this answer
    
First, i want to thank those that have submitted answers to my post. Mr West, your comment saying that I seem to know what i am doing was quite flattering, but actually I am entirely new to SQL. It is only through diligent searching and reading that i have come this far. –  user145983 Jul 20 '12 at 7:54
    
Unfortunately installing the client tools on the client machines is not an option. Others in the past have succeeded at the task i am trying to accomplish with this particular application yet details are not available. Any assistance would be greatly appreciated –  user145983 Jul 20 '12 at 8:03
    
Try setting a fixed port on the named instance anyway (you can get to that through Configuration Manager. Then try connecting using the TCP/IP option by appending the port name, so for instance, 192.168.0.1:12345, where the IP is the server IP, and 12345 is your assigned port. –  user3463 Jul 20 '12 at 17:51
    
In an effort to troubleshoot this issue i have installed SSMS on one of the client machines here locally. I can successfully connect and access the server machine and its associated data bases. From a remote machine i can successfully ping and telnet to the server machine yet can still not actually access the server. SQL is set up on the server machine using named instance Computer name\server name as follows: Mackie-Main-PC\XGPSERVER ( It should be noted that installing SSMS on each of the remote client machines is not an option ) –  user145983 Jul 23 '12 at 10:31
    
The error i see is generated by the client application itself and reads as follows: "Connection to the server has failed" In the past many others have been successful at setting up this particular configuration using SQL 2008, the same data file set i have and the client application but unfortunately details are not available. I would be more than happy to provide more specific details (screen shots, copies of and data or files, or whatever –  user145983 Jul 23 '12 at 10:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.