Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My previous home network involved just an Apple Time Capsule and an ADSL router. A LAN port of the ADSL router was simply connected to the WAN port of the Time Capsule through a straight ethernet cable. Additionally the Time Capsule provided Wi-Fi access to the Internet and to everything connected to the LAN; devices like a NAS used the ethernet switch port of the TC. Each host accessing that subnet used the DHCP provided by the TC to get its own IP address.

Now I added a layer 2 managed switch on that scenario and I'm having problems putting everything together. It's a Netgear GS724T.

Here's what I'm trying to achieve:

NAS+computers <--enet--> SWITCH <--enet--> TC <--enet--> ADSL router  
                                           |
                                         Wi-Fi  
                                           |
                                       computers  

I'd like the home network to be based on the new switch and the packets to be routed to the Time Capsule (and eventually the ADSL router) in case they cross the subnet boundaries. So according to the diagram above, I'd just like that hosts connected to the switch and the wireless LAN (served by the TC) would see each other and both be able to see the Internet.

Of course I'd prefer (but not essential) the Time Capsule to serve every host with its DHCP server.

Is there something I'm doing wrong?

[UDPATE - What's the problem?]

I was way too generic with my question, I apologize. I'm having problems because it seems the TC doesn't help with its DHCP assigning addresses to the connected hosts in the whole LAN (switch and wifi should share the same subnet). But more important there's no way I understand how to route "internet" packets from the switched lan to the TC and in the end to the ADSL router. That's the most important problem I'm facing. Unfortunately the TC "interface" seems quite restricted to a limited set of actions (you know Apple don't like opening doors) and I'm sure there's a tricky way to get unlimited access through something like an ssh session. Unfortunately if I put that way it becomes a really wide question and maybe it's addressed to Apple users only, who may help fixing such a (IMO common) setup.

I may try connecting the switch directly to the adsl router...but would it work? I may try completely remove the TC to build an initial setup and see if it works. I'd like to put it again later because I want to add wifi extent to the lan.

I'll wait for a while for someone with specific suggestions

share|improve this question

migrated from serverfault.com Jul 14 '12 at 19:51

This question came from our site for professional system and network administrators.

1  
What you've described should work fine. What problems were you having with that setup? –  Spiff Jul 14 '12 at 20:39
    
@Spiff First of all I'm trying to understand if the above scenario may work.. and you reassured me about that, thanks. Anyway if there's not anyone who can give me well known details because they already know what I'm talking about, maybe I can consider your reply the best. Actually I asked if I'm doing wrong and you told no. Now I added some more details to the question..hope to get some feedback. –  Diego Jul 15 '12 at 13:32

1 Answer 1

up vote 1 down vote accepted

It turns out that using the AirPort Utility the scenario could be easily solved. I was so skeptic I didn't even tried before. What I did was going to the Network tab and choosing the option Router = "DHCP and NAT". Of course my network is still messed up I guess, but now everything works as expected. I guess I need a better network understanding because I'll make any step further on this setup. Thank you all for your interest on my problem

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.