Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell XPS 1640 laptop (aka Dell Studio XPS 16), running Vista. Whenever the laptop wakes up from sleep, my Broadcomm LAN card immediately dies. Any attempt to access it completely locks up whichever program I use to access it. There appears to be no way to re-awaken the card, other than rebooting; note that Vista does not even shut down properly if some program is waiting for the card. So far, I have tried the following:

  • Disabled the "allow your computer to shut down this device to save power" in the device properties. This had no effect.
  • Attempted to disable and then enable the card in the device properties. No effect.
  • Tried ipconfig /renew: this locks up ipconfig to the point where I can't even kill its process.
  • Force-install updated drivers from broadcomm: no effect.

Does anyone have any other ideas ?

share|improve this question
    
have you tried manually disabling the LAN connection before putting the laptop to sleep? then enabling it after waking up. (you may have tried this, but your mention of disabling the card is unclear as to when.) –  quack quixote Oct 20 '09 at 10:54
add comment

3 Answers

Have you tried restarting the network connections service from services.msc it's a bit brute force but it might work, otherwise it's sounding like a hardware issue.

share|improve this answer
    
I've just tried it, and Windows could not shut down the service, no matter how hard I tried. So, what do I do now ? –  Bugmaster Sep 23 '09 at 1:14
    
Does it record any events in the system log when it fails? –  Col Sep 23 '09 at 7:25
    
Sorry, Col, but I'm not actually sure where to find the system log -- could you help me out ? –  Bugmaster Sep 23 '09 at 16:52
    
If you're using XP it's in control panel admin tools and in the event viewer there is a section for system at the left. You can also get to the event view by doing start-run-eventvwr.msc –  Col Sep 24 '09 at 7:25
add comment

Some ideas :

  1. Look in your BIOS for the suspend ACPI options and try to switch modes among "S1 and S3", "S1", "S3" etc.
  2. Turn off Hybrid sleep.

Manipulations that don't help should be undone.

share|improve this answer
add comment

I have tried all the remedies offered on these threads so far, with no luck. But now, I'd finally upgraded to Windows 7, and the problem seems to have gone away. It looks like the Vista driver for my network card must have been faulty. Thank you all for your help, however !

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.