Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on WIN 7. I found that windows is using ANSI, not ASCII. So when I type ALT + 224 i get Ó, instead of α. To get α I have to manually copy it from the windows character map every time I want to use it. As you can imagine, this gets very tedious when I am trying to type in Attic Greek. Is there no combination to enter α? If not, is there some solution to this?

share|improve this question
    
Do you want to type in greek? –  soandos Jul 15 '12 at 4:07
    
I'm using windows and I get α. –  ekaj Jul 15 '12 at 4:09
    
Are you using WIN7? I might have been different on vista or xp. –  irikkkkk Jul 15 '12 at 4:13
    
@irikkkkk, what OS are you using? –  soandos Jul 15 '12 at 4:41
    
@soandros, windows 7 –  irikkkkk Jul 15 '12 at 4:46
add comment

1 Answer

up vote 4 down vote accepted

As you have already discovered, the characters resulting from character codes between 0 and 255 depend entirely on the encoding that is used.

Windows doesn't use neither extended ASCII nor ANSI (usually Windows-1252); it actually depends on the application.

For example, Alt + (2, 2, 4) gives on my machine:

  • α in Notepad and on the command prompt.

  • à in Google Chrome's omnibox, but α in its console and this very text area.

  • In Notepad++, a with ANSI, α with UTF-8.

For a more consistent behavior, just use Unicode character codes:

The key combination Alt + (9, 4, 5) – or Alt + (+, 3, B, 1) if you set the registry key HKEY_CURRENT_USER\Control Panel\Input Method\EnableHexNumpad to 1should result in a α in every application that supports that character.

Sadly, that isn't the case:

  • The decimal char code results in in IE's address bar, while the hexadecimal one just beeps.

  • The decimal char code results in in Notepad++ with ANSI and ¦ with UTF-8.

  • The hexadecimal char code results in a in Notepad++ with ANSI and α with UTF-8.

Summary

  1. Set HKEY_CURRENT_USER\Control Panel\Input Method\EnableHexNumpad to 1.

  2. Use Alt + (9, 4, 5) or Alt + (+, 3, B, 1) in applications with full Unicode support.

  3. Fall back to trial and error in applications that lack full Unicode support.

share|improve this answer
    
Have you tried prefixing with a 0? Ie. ALT-0224 gives à consistently (here), but ALT-224 gives Ó (position 224 in DOS-Western Europe code page). [I don't have the hexadecimal entry set.] As I understand it the zero prefix forces interpretation as a Unicode code point. –  Richard Jul 15 '12 at 7:45
    
The 0 is used to indicate a Unicode character when the char code is ambiguous, which is only needed between 0 and 255 with our code pages (although 0 - 127 will always be ASCII). [Alt] - 0945 will result in ±: Since the 0 is out of place here, the application falls back to non-Unicode and wraps at 256 (i.e., 256 is congruent to 0, 257 to 2, etc.). ± char code is 177, where 945 = 3 * 256 + 177. –  Dennis Jul 15 '12 at 12:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.