Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My network consists of:

Netgear DG834N ADSL Modem (4 port)

Connects to...

Netgear GS608 V2 8 Port Switch This has 1 PC & a NAS drive connected to it.

It then has a Cat6 cable connecting it to...

(another) Netgear GS608 V2 8 Port Switch This has a Popcorn Hour A110 and an Xbox 360 connected to it.

It then has a Cat6 cable connecting it to...

(another) Netgear GS608 V2 8 Port Switch This has a SkyHD box, HTPC and an AV receiver connected to it, and has a short Cat6 cable connecting it to an Airport Extreme (for wireless)

Until recently, this setup has worked flawlessly, however, I am now experiencing major problems from the middle/2nd netgear onward in the chain. When using any devices hooked into the first GS608, I have no issues, but as soon as I try to stream anything (via my popcorn hour) at the 2nd GS608, or via the HTPC (at the 3rd GS608), it just bombs out. Pinging from the HTPC back through the 3 GS608's shows frequent timeouts.

I've tried swapping all 3 of the GS608's around to different locations in the network to try and isolate if 1 is faulty, but the result is the same, from any machine on the network.

If I remove one of the GS608's out of the equation (it can be any one of the 3), the problem goes away but as soon as I reintroduce a 3rd one, the problem comes back.

All cables are brand new Cat6 with molded ends (I've not made them).

Any ideas what might be causing this?

share|improve this question
    
I've also seen GS608v2's bomb out until being power-cycled, but I could never reproduce it reliably. I suspect flow-control handling may be involved. Can you configure all the devices on your network not to negotiate or use ethernet flow-control? –  Spiff Jul 15 '12 at 16:35
    
I'm a network novice, but can see Flow-Control options against the properties of my network cards in the PC's on the network (I don't have any way of configuring the network hardware on the Popcorn Hour A110, Sky or Amp though). I don't know what the various options mean under the Flow Control setting on the PC's. –  marcusstarnes Jul 15 '12 at 17:58

1 Answer 1

up vote 1 down vote accepted

It turns out that 1 of the 3 switches was the problem. I replaced it with a brand new GS608 (v3) and everything as working against as it should. I thought that I'd isolated each switch initially and proven that they were each fine, but obviously not.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.