Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install a Counter-Strike: Source server on my Ubuntu box.
I am using the HLDS tool in the guide here.

I have downloaded hldsupdatetool.bin to my home directory (/home/chris/cssserver/hldsupdatetool.bin) and run the commands it's told me to, but the file never seems to run. Here's my terminal:

chris@ks395362:~/cssserver$ wget http://storefront.steampowered.com/download/hldsupdatetool.bin
--2012-07-15 21:29:56--  http://storefront.steampowered.com/download/hldsupdatetool.bin
Resolving storefront.steampowered.com... 87.248.210.253, 87.248.210.254
Connecting to storefront.steampowered.com|87.248.210.253|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3513408 (3.4M) [application/octet-stream]
Saving to: `hldsupdatetool.bin'

100%[======================================>] 3,513,408   10.4M/s   in 0.3s

2012-07-15 21:29:57 (10.4 MB/s) - `hldsupdatetool.bin' saved [3513408/3513408]

chris@ks395362:~/cssserver$ sudo chmod +x hldsupdatetool.bin
chris@ks395362:~/cssserver$ sudo ./hldsupdatetool.bin
chris@ks395362:~/cssserver$ ls
hldsupdatetool.bin
chris@ks395362:~/cssserver$ file hldsupdatetool.bin
hldsupdatetool.bin: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), stripped

The binary is meant to extract steam into that directory when it's run, but it doesn't do anything. If I just run ./hldsupdatetool.bin without sudo I get this error:

-sh: ./hldsupdatetool.bin: No such file or directory

What gives?

share|improve this question

2 Answers 2

up vote 4 down vote accepted

First, you should not run this tool with sudo.

Second, it's most likely that you are on a 64-bit system, but this is a 32-bit binary. Try installing the 32-bit compatibility libraries:

sudo apt-get install ia32-libs

After that, try again with:

./hldsupdatetool.bin

If it still refuses to start, run this command and paste the output in your original question:

ldd ./hldsupdatetool.bin
share|improve this answer
    
Thanks, that's the reason. However, when I try to install ia32-libs it fails because it needs a dependancy called lib32v4l-0 (>= 0.5.0), then I try to install that I get a dependency error saying: Depends: libv4l-0 (= 0.8.0-1) but 0.8.5-3ubuntu2 is to be installed –  Mark Twaign Jul 15 '12 at 20:08
    
That's a separate question. :) But to answer it, you should do sudo apt-get update; sudo apt-get upgrade first. –  Michael Hampton Jul 15 '12 at 20:09
    
That didn't fix it, but as you said that's a whole other question. Thanks for answering this one :) –  Mark Twaign Jul 15 '12 at 20:26
    
@MarkTwaign Time to upgrade to 12.04 perhaps? :) –  Michael Hampton Jul 15 '12 at 20:26
    
My server host offers it but says it's in beta, would it not be better to run a stable version? –  Mark Twaign Jul 15 '12 at 20:34

The package ia32-libs has been expanded to include a lot more stuff than is needed as of 12.04. Installing only lib32objc3 seems to work though. Tested on fresh install of 12.04.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.