Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Google Search Appliance which is really just a Poweredge 2950 II. It's running Windows 2008R2 x64. I have a Linksys WMP600N PCI card installed in the riser.

Due to current temporary housing arrangment, wired connectivity is not possible. This is for a home lab, non-production system.

BIOS is up to date running v 2.7.0. I am running the most recent driver from Linksys, V3.2.7.0. These are the Windows 7 x64 drivers. The device manager shows the WiFi card as enabled, device is working properly.

The dual onboard NICs are disabled and I have checked all the items in the cards properties except IPv4. I have uninstalled, deleted the driver and reinstalled in Safe Mode.

In the Network Connections pane it shows the card as disabled. When I right click the adapter and choose Enable, a window pops up and says:

  1. Enabling
  2. Enabled

after which the Network Connection pane shows the adapter as still disabled. How can I get this adapter enabled and picking up WiFi?

share|improve this question
    
Try seeing if the linksys wireless manager is interfering with the native wireless manager. –  DrinkJavaCodeJava Jul 15 '12 at 21:29
    
I have not installed the Linksys wireless management, I only installed the driver through the Device Manager. –  Pangea Jul 15 '12 at 21:43
    
    
That link leads to the WLAN service which is not installed by default on Server 2008R2. After adding the 'Wireless LAN Service' feature the service is enabled and I can detect WiFi networks. Thanks. –  Pangea Jul 15 '12 at 22:48
    
I found a solution, and it involves temporarily bridging the wireless and lan connections (then unbridging). See technopaideia.blogspot.com/2013/11/… –  user277473 Nov 27 '13 at 18:34
add comment

1 Answer

WLAN service is not installed by default in Windows Server 2008. In order to turn on Wireless LAN and WLAN AutoConfig service in Windows Server 2008 and Windows Server 2008 R2, go to Server Manager (in Administrator Tools). Go to Features branch and click on Add Features. Click and tick the check box for Wireless LAN Service. Complete the installation wizard to install wireless support.

I found this solution at MyDigitalLife

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.