Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

From the time I installed mint 13 (cinnamon) I cant hibernate and resume correctly . every time when i do pm-hibernate the system hibernates but when i resume cinnamon is not loaded , the icons and all are a mesh and if i try to restart cinnamon the system freezes (same if i try to do cinnamon --replace on a terminal).

I have plenty of swap (10GB and my ram is only 2GB)

             total       used       free     shared    buffers     cached
Mem:          2013       1773        240          0         20        356
-/+ buffers/cache:       1396        616
Swap:        10313        255      10058
share|improve this question

1 Answer 1

up vote 2 down vote accepted

As you didn't state your hardware details, only a generic answer is possible. I'd guess some part of your hardware is causing trouble on suspend/resume, as it is often the case (some video-drivers are know for that). That's where SUSPEND_MODULES kicks in: modules defined here are unloaded on suspend, and reloaded on resume -- so concerning the problematic hardware it looks like shutdown/startup. To give you one reference: Here is one thread on the Linux Mint forums dealing with similar trouble on a Sony Vaio, and here's another dealing with sdhci causing trouble on a HP Pavilion. These are just examples, you will find many more on a search for "SUSPEND_MODULES", best with some hardware specs (hint: some wifi hardware also often is the cause for this kind of trouble, same applies to graphics and tv-cards).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.