Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am not a Linux newbie, but haven't touched SuSE in a very very long time (last time I tried it, it was SuSE 7!). Finally now I felt like giving it a try, and many things seem strange or unnecessarily complex. I have a series of questions.

  1. How do I ensure that my packages are uptodate? It sounds silly, but I tried the obvious methods already. I have disabled the default repositories that show up when you do zypper lr, and added Tumbleweed and packman repositories (Essentials, Multimedia, Extra). Then I did a sudo zypper ref --force and then sudo zypper dup, and it tells me many dependencies are not met. I have already added solder.allowVendorChange=true to /etc/zypp/zypp.conf, so it should not care which repository the latest versions are in, and just upgrade to it. Even when I chose to skip the packages with unmet dependencies, and seemed like quite a bit happened in the background, I opened Firefox afterwards and the version was 7! I am guessing things did not go as expected. But of course this is not a problem with SuSE, but I am not understanding the system right. How do I do it right?

  2. When I start typing arguments of a command, for example sudo zypper install, when I type sudo zypper ins and keep hitting TAB, nothing happens! It always worked in Ubuntu and I feel very uneasy with this. Is this how SuSE is supposed to be?

  3. When I try to install something, and I start writing its name, even though the package exists and I am sure of it, hitting TAB does not autocomplete it. This is also quite inconvenient. Why is it not happening?

There are many things in SuSE that are really great, and I think I will stay with it and not go back to Ubuntu once I settle these very rudimentary issues. But right now they are giving me a lot of grief! Please help!

share|improve this question
up vote 1 down vote accepted

1) "I have disabled the default repositories" > Do not do this. Even Tumbleweed has dependencies into the default distribution repositories. Instead, just give them a lower priority. (There are excellent opensuse-wiki-pages on how to use Tumbleweed. They are worth of being read in detail.)

2) The standard behaviour of bash (in openSUSE at least) does only perform auto-completion on commands (files). "Zypper" is a command, while from bash's point of view, "install" is just a parameter of zypper, so it will not auto-complete. Btw, if you're a lazy typist, "zypper in" works equally.

3) Again, this is not the job of bash. If you do not know the full name of a package, you can use the search features provided by e.g. zypper or YaST.

Today's openSUSE is rather far away from the old SuSE systems. It makes a lot of sense to learn some of the basics from scratch.

share|improve this answer
I thought, since SuSE and Ubuntu are both flavours of Debian, some barebone basics would be similar. I know SuSE loves applying its own kernel patches, for which, driver installation and some other things are different, but I was expecting autocomplete and userfriendliness to improve at least to this extent. When you do not know or cannot remember the variable names to use with gsettings to change all system defaults in Ubuntu, for example, hitting tab helps you every step of the way. It is not really a solution for lazy people, it makes things much less of a memory game. Thanks for the reply! – Subhamoy Sengupta Dec 13 '12 at 13:37
SuSE is NOT a flavour of Debian. Mist distributions apply individual patches to the kernel, so does Ubuntu. Auto-complete is a feature of bash, not the kernel. – ernestopheles Dec 13 '12 at 14:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .