Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A computer, with Windows 7, can't access any website by domain suddenly.

  • Whether this computer use a wired link or connect to the WLAN, The fault persists
  • IP and DNS obtained automatically, and seems normal (ipconfig /all return the correct info)
  • I can visit websites by using HTTP proxy
  • The DNS server is available, other computer in my room works properly.
  • I can ping myself, the gateway and any other IP, but domains
  • I can use nslookup and obtain the correct IP info
  • There are some error information in the event log about dns client events explaining the client can not verify the DNS server available
  • Windows network diagnosis explain that Windows can't communicate with the device or resource (Primary DNS Server)

I guess the dns client should be blame. I tried to do the following things but the fault persist.

  • Reinstall the driver of network adapter
  • Reset TCP/IP (netsh int ip reset)
  • Reset Winsock (netsh winsock reset)
  • Reset LSP

I don't want to reinstall the whole os, what should I do?

share|improve this question
add comment

3 Answers 3

Use a wired connection and boot into Safe Mode with Networking (tap F8 on startup for Advanced Boot Options, it will usually be the third option, after Repair Your Computer and Safe Mode).

This is an informative comparison point as Windows starts with only core drivers and services, and no third-party software.

If it works in safe mode with networking, it tells you there is something loading on normal boot that is interfering, which gives you two options.

  1. Run Windows system restore and choose the latest known working date among the restore points (check if the restore point descriptions note anything unusual - anything besides "System scheduled checkpoint" could be informative). I would do this first, as it performs an entire registry rollback, and then go for the more granular option 2 if this fails.

  2. Open msconfig and have a look at what services and programs are starting on a normal boot. In the services tab of msconfig, check "Hide all Microsoft services" at the bottom, then make a note of all remaining services and disable them. In the startup tab of msconfig, make a note of all the checked items and disable them. Reboot to normal mode. If everything works in normal mode after this, you need to go back into msconfig and selectively enable the important things, among these your security package. If it stops working after reenabling something and rebooting, you have found a culprit.

If it does not work in safe mode with networking, do option 1 above.

In my mind the primary suspects for the behavior you are describing would be malware, a hung security package or - possibly - a windows update gone bad. If you get it working, update your security package and do a full scan.

share|improve this answer
    
Oh darn, this is an old question that got bumped to the top. Nvm, leaving my answer for reference. –  mxl_ Apr 5 '13 at 22:28
add comment

Is there anything in the hosts file which is stopping this seeing the local network C:\WINDOWS\system32\drivers\etc\hosts (open with notepad)

Did you try ipconfig /flushdns

Can you ping the domain name server?

It sounds like the computer is having issues resolving DNS, I would guess a re-installation is overkill for this. Let me know if any of these help

share|improve this answer
    
The only other time I've had this was malware - did you do a full virus/malware scan? Also, is it limited by browser? –  Dave Rook Jul 16 '12 at 15:17
    
The host file has default contents (ALL commented with #), when I try to flush dns cache I got this "Could not flush the DNS Resolver Cache: Function failed during execution." I found the DNS Client service was stopped but the start type was auto. I try to manually start the service. And then flush dns cache successfully. Then I try to ping a domain, failed again. look back to services.msc, the DNS client service stopped again –  horsley Jul 16 '12 at 15:28
    
Full virus check has done before, kill some virus named W32.sality.at –  horsley Jul 16 '12 at 15:30
    
I have tried Firefox, Chrome and IE. Same problem –  horsley Jul 16 '12 at 15:44
    
Sorry, just to be clear, did you check for malware - we've had similar issue and MalwareBytes detected it and cleared it but Kaspersky did not. –  Dave Rook Jul 17 '12 at 7:30
show 1 more comment

You mentioned that you found a virus on your machine. You should really consider reinstalling your OS since the virus may be still there, e.g. hidden in some system restore images.

The instructions below may give you strange results if you still have some malware running.


To check for issues with your DNS server, you could try to check if the Google DNS servers are working for you (as already mentioned here):

nslookup
> server 8.8.8.8
> superuser.com

The reply should be something like:

Server:         google-public-dns-a.google.com
Address:        8.8.8.8

Non-authoritative answer:
Name:   superuser.com
Address: 69.59.197.21

If you don't get the same IP for superuser.com then you may have a problem with your routing/connection or probably some malware.

If it works try to set a static primary DNS server for your connection. Type this as Administrator:

netsh dnsclient set dnsservers name="Name of your Connection" source=static address=8.8.8.8

Check your browsers again and see if things are working now. If yes then your DNS server has some problems. You can keep using the Google DNS servers while fixing your own.

If it's still not working try using curl (Windows packages are at the bottom of the page) to see if it is a browser issue:

curl superuser.com

You should see the HTML source of this site. If this works then your browsers do something strange.

Another note, probably unrelated: Check if you have any strange proxy settings in your Internet Explorer connection settings. These settings are system-wide and may be the reason for (not DNS-specific) connection issues.


To set your primary DNS server back to DHCP type this as Administrator:

netsh dnsclient set dnsservers name="Name of your Connection" source=dhcp
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.