Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When installing/updating tools in Windows System Control Center, I get an error that says "wrong update version". The error is not any more descriptive than that.

enter image description here

Other tools download and install/update just fine, but certain ones - particularly password tools - give that error all the time. The only tool I've had give the error which is not a password tool is Process Explorer.

I run this same software on both my home and work computer. I have local Admin rights on both. The work computer is the only one that gives me this trouble - there's no problem installing any of these on my home computer.

What could cause these errors?

share|improve this question
up vote 1 down vote accepted

This error is likely caused by one of two things, though neither of them is really hinted at by the error description:

  1. The program you're trying to update is already running, and therefore the updater cannot modify it.
  2. Your antivirus software is detecting the tool as malware. This often happens with advanced tools, especially in the case of password recovery tools.

In my particular case, it was a little of both.

For Process Explorer, it was reason #1. I like to keep Process Explorer running in my system tray on startup, so it's most likely running whenever I check for an update as well.

For the password recovery tools, it was #2. I checked the logs of the Antivirus software, and saw that all the tools I was having problems with (except Process Explorer) had been flagged with things like "Hacktool" or "Trojan.Gen" - some signatures even had the program's actual name. All of them had been acted upon in some way: Deleted, Quarantined, or just "Access Denied".

How do you fix this?

Well, #1 is easy. Just exit the tool before you update, and re-run it if desired after updating is complete.

The #2 cause isn't so easy if the system isn't yours. If it is yours you can either choose to use an Antivirus program that doesn't consider your tools as malware, or set your Antivirus program to ignore them. If it's not your system, then you may not be able to make these modifications. If you really need the software, you'll have to go through whatever process your organization has in place for whitelisting such tools.

If you don't really need the software, and just want to get rid of the errors, you can disable updating for the offending tool and hide it from the list. Right-click the tool in WSCC, and select Properties. Then go to the Options tab and select "Don't show in the list". To un-hide the item, you'll have to reverse the process but remember to show hidden items first.

share|improve this answer

For me UAC was blocking access to Program Files. Starting WSCC as Administrator solved the issue for me.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .