Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to gain access to my Windows 2008 R2 server via SSH. I have a Remote Desktop connection, but I need to upload my files to the server. For SSH servers on the Windows server, I've tried Cygwin+OpenSSH, but that only starts around one in twenty times that I try it, so I've installed FreeSSHd and start it up manually. FreeSSHd generated a private key called "RSAKey.cfg" when I installed it, and I tried copying this into a file and converting it to .ppk using PuTTYgen on my PC so that it might work with WinSCP or the FileZilla client. I made a user that can use Shell, SFTP, or Tunnel, and is set to authenticate with public key authentication, but when I try to login as SFTPuser@[IPAddress], I get the following error in WinSCP:

Server refused public-key signature despite accepting key!


  1. What does this mean?
  2. What is the correct procedure for getting a matching public/private key pair to work with each other in FileZilla + WinSCP?
share|improve this question
I'm running into the same wall. I found this which might be of help:… -- Additionally, you are probably already aware: in your local desktop you can select files, CTRL+C to copy them, and then in RDP, use CTRL+V to paste them -- this is very insecure however, so you may want to put the files into an encrypted archive file first, etc... – BrainSlugs83 Feb 7 '14 at 21:55
Had the same with KypM SSH server on Windows - problem was solved with proper configuration of public/private keys. Log of KTS helped a lot. Link to question on KTS forum. – Andrii Kalytiiuk Aug 15 '14 at 11:57

You must log in to answer this question.

Browse other questions tagged .