Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Some days ago I was able to scp to the remote server from my windows server 2003 using cygwin to copy the id_rsa, using scp (id_rsa.pub location) [email protected] now it(scp) seems to be not working. I have not installed or removed any of the cygwin packages.

I can still automatically connect to the server using ssh. On the same server while working form other Ubuntu machine, scp and ssh are working perfect. It does not even prompt for the password while using scp command.

scp -v c:/outfiles/[email protected]:~/temp/headers.csv
Executing: /usr/bin/ssh -x -oClearAllForwardings=yes -n -v -- c scp -v /outfiles/headers.csv [email protected]:~/temp/headers.csv
OpenSSH_6.0p1, OpenSSL 1.0.1c 10 May 2012
debug1: Connecting to c [XXXXXXXXXX] port 22.
debug1: connect to address XXXXXXXXXX port 22: Connection timed out
ssh: connect to host c port 22: Connection timed out 

While ssh has the following debug message:

    $ ssh -v [email protected]
    OpenSSH_6.0p1, OpenSSL 1.0.1c 10 May 2012
    debug1: Connecting to example.com [XXXXXXXXXX] port 22.
    debug1: Connection established.
    debug1: identity file /home/Administrator/.ssh/id_rsa type 1
    debug1: identity file /home/Administrator/.ssh/id_rsa-cert type -1
    debug1: identity file /home/Administrator/.ssh/id_dsa type -1
   debug1: identity file /home/Administrator/.ssh/id_dsa-cert type -1
   debug1: identity file /home/Administrator/.ssh/id_ecdsa type -1
debug1: identity file /home/Administrator/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.8p1 Debian-7ubuntu1
debug1: match: OpenSSH_5.8p1 Debian-7ubuntu1 pat OpenSSH_5*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.0
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA (host key XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX)
debug1: Host 'example.com' is known and matches the ECDSA host key.
debug1: Found key in /home/Administrator/.ssh/known_hosts:1
debug1: ssh_ecdsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Offering RSA public key: /home/Administrator/.ssh/id_rsa
debug1: Server accepts key: pkalg ssh-rsa blen 279
debug1: read PEM private key done: type RSA
debug1: Authentication succeeded (publickey).
Authenticated to example.com ([xxxxxxxxx]:22).
debug1: channel 0: new [client-session]
debug1: Requesting [email protected]
debug1: Entering interactive session.

Another question I would like to add here is:

I am able to start the cron service but the cron job doesn't work. I receive an error saying (ORPHAN)no password set for the cron job while querying with cronlogs. There seems to be some problem with my Cygwin settings apparently, but I am not able to diagnose them. Besides the numerous search in the cygwin FAQ almost 2 days of googling still in a same situation, stuck. Basically I am trying to automate a file transfer using scp any other option to do that would help, I have been stuck quite long.

May be not a good idea but I got ask this. Can firewall be suspected for the cause, if so how verify that? I had read somewhere aboutnetstat but did not bother to continue, justified or miss-justified by the idea of ssh was successful using the same port no. 22.

share|improve this question
    
solved, thanks any way, it seemed to me due to bad command, or windows like command, Its all running now, hurre... $ scp /cygdrive/c/outfiles/filename.txt [email protected]:~/temp/ instead of $ scp c:/outfiles/filename.txt [email protected]:~/temp/ though it will not produce any error but seems that it does not recognize the windows like path. In cygwin help file they write that it may work but seems sometimes it does not work. Got lots of trouble with this one. Last time was also the same problem but got it thorough later it was not in my mind again. My apology for the trouble. –  tough Jul 17 '12 at 9:38
add comment

migrated from stackoverflow.com Jul 17 '12 at 2:54

This question came from our site for professional and enthusiast programmers.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.