Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an old Red Hat Linux box that I use, amongst other things, to run Samba. My Vista and remaining Win XP PC can access the p/w-protected Samba shares.

I just set up a new Windows 7 64-bit Pro PC. Attempts to access the Samba shares by clicking on the Linux box's icon in 'Network' from this machine gave a Logon failure: unknown user name or bad password. message when I gave the correct credentials.

So I followed the suggestions in Windows 7, connecting to Samba shares (also checked here but found LmCompatibilityLevel was already 1).

This got me a little further. If click on the Linux box's icon in 'Network' from this machine I now see icons for the shared directories. But when I click on one of these, I get \\LX\share is not accessible. You might not have permission... etc.

I tried making the Win 7 password the same as my Samba p/w (the user name was already the same). Same result.

The Linux box does part of what I need for ecommerce - the in-house part, it's not accessible to the Internet. As my Linux Fu is weak, I have to avoid changes to the Linux box, so I'm hoping someone can tell me what to do to Win 7 to make it behave like XP and Vista when accessing this share.

Help please!?

Thanks


Thanks for replying @Randolph. I had set 'Network security: LAN Manager authentication level' to Send LM & NTLM - use NTLMv2 session security if negotiated based on the advice in Windows 7, connecting to Samba shares and had restarted the machine, but that didn't work for me.

I'll try playing with other Network security values.


I have now tried the following:

Network security: Allow Local System to use computer identity for NTLM: changed from Not Defined to "Enabled".

  • Restarted machine

Still says "\LX\share is not accessible. You might not have permission..." etc.

Network security: Restrict NTLM: Add remote server exceptions for NTLM Authentication (added LX)

  • Restarted machine

Still says "\LX\share is not accessible. You might not have permission..." etc.

I can't see any other Network security settings that might affect this. Any other ideas please?

Thanks

Roy

share|improve this question
    
Have you restarted the windows machine after you changed the samba share password? –  Sion Jul 17 '12 at 6:06
    
Yes, I had, thanks @Sion –  Roy Grubb Jul 17 '12 at 9:49

3 Answers 3

Have a look on the Windows 7 box in Local Security Policy, under Local Policies > Security Options. There's a series of NTLM-related policies to play with.

The LmCompatibility option you've already changed in the registry is governed by the policy

Network security: LAN Manager authentication level

which in your case should be set to "Send LM & NTLM - use NTLMv2 session security if negotiated".

You will need to restart the Windows machine for this to take effect.

share|improve this answer
    
Thanks @Randolph. –  Roy Grubb Jul 17 '12 at 9:40
    
Still unable to access from Win 7 though. See question, which I have added to. Roy –  Roy Grubb Jul 18 '12 at 7:54

Control Panel - Administrative Tools - Local Security Policy

Local Policies - Security Options

Network security: LAN Manager authentication level Send LM & NTLM responses

Minimum session security for NTLM SSP Disable Require 128-bit encryption

share|improve this answer

Check your smb.conf file under [global] and see if the following is in that section:

ntlm auth = no lanman auth = no client ntlmv2 auth = yes

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.