Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When using the Data menu item in Excel to import data from web to spreadsheet, the hyperlinked items lose the link and appear just as text (for example try this: Test - How to overcome this?

Note: I am trying to import the data table and use the link in the first column from my spreadsheet.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

When you choose your table to import, select "options" in the upper right corner and deselect "Import blocks into columns". Click OK then finish your import. This will import the table with its existing formatting, including the hyperlinks.

enter image description here

share|improve this answer
Please note that in Excel 2007 the dialog box for options is slightly different, and I had to select the "Full HTML formatting" to what you have suggested to make it work. Thanks again for your help. – NoChance Jul 17 '12 at 15:00
In MSexcel 2013, After clicking "Data" tab and "from web". Click on the upper right corner "Options" as CharlieRB said. In Web Query Options window that will be opened, 1. select Full HTML formatting and 2. deselect Import <PRE> blocks into columns as CharlieRB said. – sandy Aug 24 at 6:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.