Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I don't get an error about the db not existing or being populated. I get nothing. I know for a fact that the things I'm searching for exist on my box. I even tried locate bin or locate Users. I get nothing!

I tried updating the db: sudo /usr/libexec/locate.updatedb, but still nothing.

sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.locate.plist says that it's already loaded.

Any suggestions?

share|improve this question
    
It says it's already loaded :( – Jeremy Detrempe Jul 18 '12 at 0:20

An alternative for some things is mdfind (mdfind and related utilities are the command line interface to Spotlight). But it only finds things that Spotlight itself would return.

But keeping the focus on locate, check to make sure that /var/db/locate.database is actually populated. Or to start from scratch disable locate via launchctl, run locate.updatedb as root then reload locate via launchctl. This should leave you with a working database.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .