Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A few office machines seem to have lost the ability to receive RDP connections.

Looking at two of the machines - nothing is listening on 3389, tested with: netstat -ano | findstr 3389 and rdp-tcp isn't listed in qwinsta

Have tried the following to start 'Remote Desktop Services' listening on 3389 to no avail

  • sfc /scannow
  • regsvr32 remotepg.dll
  • left work domain then disabled rdp / re-enabled rdp
  • trying starting extra services that may have any impact
  • disabling all firewalls/antivirus
  • disabling ipv6 on the adapter
  • re-installing network drivers
  • checking if KB972260 was installed (it wasn't)
  • copying TerminalServices reg keys from known working machine
  • reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v fDenyTSCo nnections /t REG_DWORD /d 0 /f
  • performed gpupdate and checked policies in rsop.msc

rsop.msc showing enabled terminal services

rdp enabled and set to accept any version

rdp services started rdp services dependencies

share|improve this question
Is there possibly a GPO on the domain that might be administratively disabling it? – Garrett Jul 18 '12 at 1:01
added cropped picture from rsop.msc - policies are to enable rdp – Thermionix Jul 18 '12 at 1:37

Try checking the security level of the rdp on both machines (the one you're connecting to and the one you're connecting from). If they are on different levels that can cause the issue you are having.

"By default, Remote Desktop connections are encrypted at the highest level of security available (128-bit). However, some older versions of the Remote Desktop Connection client application do not support this high level of encryption."

share|improve this answer
both machines are set to allow connections from any version – Thermionix Jul 18 '12 at 2:26
oh ok. By "disabling all firewalls/antivirus" you mean on both machines right? Sorry, but I have to ask... – imtheman Jul 18 '12 at 2:34
if the machine doesn't have a service listening locally on port 3389 then something is wrong with the service. at this point the external network doesn't come into it – Thermionix Jul 18 '12 at 2:43

Did the machines get moved to a different OU before you removed them from the domain? If the OU had RDP disabled, when you left the domain, the policy may have remained behind. You might try rejoining the domain and ensuring RDP is enabled via group policy.

share|improve this answer
just tried a gpupdate to refresh the group policy (which is applied to many more machines which have working rdp services) and rebooted - still not working – Thermionix Jul 18 '12 at 5:30
Have you checked the event log on the non-listening machines for any errors? – ND Geek Jul 19 '12 at 2:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.